Cycles is very slow now

The rendered mode of Rhino 6.22 is much more slower than it was a few months ago. I use Nvidia Quadro K2000M GPU and have the latest driver from Nvidia. I reduced all Cycles settings to 1/4 of defaults, but it had no impact on speed. The raytraced mode does not work at all - the viewport is black.

Are you 100% sure Rhino isn’t using the integrated gpu instead of the Quadro?
And have you checked that Cycles is using the GPU and not the CPU?
(The CPU should not return a black screen though.

Cycles works perfectly fine on my laptop:
(But this is on a rtx2070 max-q though)

Compared to the CPU (an 8700k):

The Quadro K2000m has 384 cuda cores vs the rtx’s 2304 cuda cores, so you should expect around 1 minute and 48 seconds on the same scene at the same resolution. That is 30 seconds slower than my cpu, so you might benefit from using the CPU with Cycles none the less.

Hope that helps with your bugtracking and use.
(Note: I don’t work for McNeel, nor work on developing Cycles, so I don’t know anyting about any changes that can have been made lately, only that it works as expected on my systems)

Here are my viewport size for the test I just did:

And the file if you want to have a go:
twistybend.3dm (166.2 KB)

Note: I sat raytraced to stop at 300 iterations.

I am experienced Rhino user, so I do not make such silly mistakes. (I have reported more bugs than anyone else.) A minute ago I compared CUDA and CPU performance. They are identical - same speed and same black raytraced viewport.

1 Like

So am I, and that is why I ask about being 100% sure, even we do make silly mistakes you know… I have lost count on the amount of times I have tweaked something that I was SURE I had sat back to default only to realize I had not… :slight_smile:

So I hope you don’t mistake me spening my spare time on trying to help you for being a silly troll with nothing better to do than to try to step on you :slight_smile: I know very well who you are and have read tons of your posts!
I really know how frustrating it is when hardware and software doesn’t act as expected. I fully feel you and hope you solve your issue.

If both the CPU and the GPU returns the same problem then quadro drivers should be out the equation, and maybe a dreaded reinstall of Rhino should be considered. I can’t remember what OS you are on though, is it windows 10, or 7?

Andrew -

There are two places to render.

The Raytrace Viewport mode you say is black? That is not good. Is that true with even a super simple new model?

The Render command that brings up the render window is much slower then the viewport version. It also uses Cycles now, but has some settings which slow down the rendering. We are investigating what those are specifically. The good news is the result of the rendering will be better. But, we understand the need to be able to control the quality/speed issue is important, so we do need to figure out what the actual settings are.

It makes no difference. I changed default Renderer from Flamingo to Rhino - again no difference.

You are right.

I have been around for a long time, so I know who you are.

I thought we were talking about Cycles. But by switching to Flamingo I expect that the default environment has been messed with. Normally I will set Cycles as the default, then reset to a default Rhino environment and away from the Flamingo default environment. Every time I have seen all black in the Raytrace Viewport that has been the problem. You may need to create a new default environment to get it to take.

Poking Reset to Defaults in the Render panel may sort it out.


Yes. It fixed the problem! SubD objects are invisible in the raytraced mode, but this is cosmetic flaw. (You probably gave me this advice a few months ago but I forgot it.)

Since this thread is strictly about Rhino 6, yes, that’s how it is and how it will be.