Curves only visible when selected? (with video)

Hello, I am running Rhino6 SR11. A problem that had affected me several weeks ago (same version of rhino), but went away on its own, has come back to haunt me again. This time I’m posting here to hopefully find a solution.

The problem is this: after running a command or saving a file, all curves will disappear from the viewport. I can still select them, and they are visible when selected and highlighted in yellow. But when I deselect, they stay invisible. If it happens after a command, running the UNDO command will not fix the problem. The curves stay invisible even if I undo all the way to file opening.

The only solution is to save the file and restart Rhino, use it until the problem happens again, then do the same again. The problem seems to only affect curves, even if they are in a block etc. Hatches, surfaces, picture frames stay visible. Text is also affected. Here is a video:

I tried to reproduce the problem but as far as I can tell it happens just randomly, I can’t find anything to trigger it. Curves is checked in the display options. GPU drivers are up to date. Does anyone have a solution?

have the same problem

Please run SystemInfo in Rhino and post the results here…

Hello - by the title of your video clip, it seems you may not be running a licensed copy of Rhino. If that is the case, you’re on your own… otherwise, I suggest updating to the current service release here:

as well as making sure your video driver is up to date.

Please run the SystemInfo command in Rhino and post (copy/paste) the results here.


I have a similar problem! Curves after creation not visible, but still here??? If i change line in layer from “continous” to “border” the curves are visible!!! graphic drivers are updated. rhino is updated. the problem is only on the windows-machine with “AMD Radeon Pro WX 2100”

Hi Martin - in Options >View > OpenGL please un-check ‘Gpu Tessellation’ or move the slider a notch to the left -

Any better?


Hi Pascal.

Thanks for your quick response AND it works!

Best Regards