Disappearing Curves

This has just started happening on a growing 175Mb file so I wonder if it’s a memory thing, or hopefully a setting?

  1. In perspective mode
  2. Changed to Right view
  3. ZoomExtents or ZoomSelected and the curves all disappear. Zooming with Ctrl button is ok. Change to Left view (close to origin) and all is fine, although back-to-front.
  4. The curves are selectable but invisible. New geometry is also invisible, although new annotation appears normally.

This geometry is 35m (only) from origin and I’ve found that if I project the geometry to origin, or anywhere between 10m and -100m, all appears fine - then project it back to where I need it and the curves disappear again.

Hi Brian- do the camera and target locations look reasonable in Properties for this view (nothing selected)?


Yes, the settings look fine:

Hmmm - X location is quite large- does Zoom Extents in the different views seem correct? I’m thinking there is a curve or other object farther away from the expected location and that is messing with the view extents.


Test- Wires Zoom Error.3dm (225.9 KB)

Hi Pascal, thanks for your suggestions - tried extents in the other views and it just seems to be the right view. I’ve uploaded a portion of the file here for you to try please. the file is in perspective view, so right view then zoom extents is where I have the problem.

The main curve is a projected section from a surface set originally from a maxsurf iges, although I doubt that has any significance.

This problem has been solved by restoring the default settings to the displaymode (shaded in this case). The custom settings have been re-applied and the problem hasn’t returned.

I am having a similar but slightly different issue. See attached video. This has happened several times in the last few days for me. Build 5A732 I don’t have any custom settings on the wireframe display mode.

Easy Screen Record 2015-03-19 11.20.13.mov.zip (7.0 MB)

Hi Shawn- are the curves and other objects at different levels (Z distance) from the camera? Is the camera location ‘reasonable’, that is, no gigantic or unexpected numbers in the camera or target coordinates? (ViewportProperties command)



I thought my problem was cured but it came back, so I now use a workaround as in the image attached. I see @Gerard had the same problem in another thread, where the camera seemed to be too close to the geometry. This camera adjustment fixed Gerard’s example too.

I’ve just had something very similar happen in a new Rhino model. Wireframe, small file size (<1Mb), all objects close to the origin. No imported entities. Changing the X location for the camera from 191.something to 200 fixed the disappearing curves. I’ve never seen this happen before in a parallel view.

Matt, are the objects widely spaced in 3d, relative the to camera direction? Is there any object that is not in the expected location, like a single curve way out of plane with the rest of the model, something like that? If so, Zoom Extents in a side view should zoom way out.