Cursor Alignment Issues


#1

I recently upgraded to Wenatchee 5.0 2013-12-02 (492) and have been having some issues ever since. The largest, and most impairing issue is the fact that my cursor is never aligned with where it is clicking inside the viewports. This is an issue that occurs only in the viewport itself, for when I click on the layer or object menus my accuracy and alignment is correct.

I have uninstalled Rhino and deleted all of the preferences multiple times, yet every time, this issue reoccurs. Even after reinstall, the viewports open with the grids uncentered and the cursor origin located in a weird place. When in top view when I put my cursor over the origin it shows as being 0, 125, 0.

Does anyone know how I can fix this, or is this just a glitch that I’m going to have to deal with?

Thanks,
dumu


10.7.5 vs 10.7.4
The location of "selection arrow" is not correct!
#2

Im encountering the same problem.


#3

Same here,


(Marlin Prowell) #4

I have no idea what is causing this. I’ll need a lot of help from you to diagnose this.

First, let’s determine if it due to the 2013-12-02 version of Rhino. In your Downloads folder, you should have older Rhino install files, like rhinoceros_wip_20131118.dmg. Throw away your current version of Rhino and install this older version. Does the problem still happen?


#5

Installing the older version solved the problem. I usually delete the downloads once done with them. Never thought about going back to the old one. Thanks for the help. I can now get my final project done, at least.

dumu


(Marlin Prowell) #6

This lets you continue, but the problem is not fixed. Eventually the version you are running is going to expire, and then you will be stuck. I still need your help to fix this.

You said you installed an older version, but you didn’t say which older version.

Please post your OpenGL settings so I can see your hardware and software environment, and what version of Rhino you are running.

Try downloading another copy of the 2013-12-02 version (another copy is important) and install it by dragging it somewhere else, like your Desktop. Quit your “older” copy of Rhino. Does this new download of the 2013-12-02 version still exhibit the cursor alignment problem? And if your quit the 2013-12-02 version and switch back to the “older” version, does the alignment problem immediately disappear?


#7

Ok, so I installed rhinoceros_wip_20131118.dmg, and cursor works fine. I then installed the most recent version to a folder on my desktop. When I open the newer version the problem persists, but in rhinoceros_wip_20131118.dmg it does not.

OpenGL Settings 20131118.dmg:
Software information

Software versions
Rhinoceros version: 5.0 Wenatchee 2013-11-18 (491)
OS X version: Version 10.7.3 (Build 11D2515)

Plug-ins
None

Hardware information

Computer hardware
Hardware model: MacBookPro9,2
Processor: Intel Core i7-3520M CPU @ 2.90GHz
Memory: 8 GB
Architecture: Intel 64 bit

Video hardware
Graphics: Intel HD Graphics 4000 512 MB
Memory: 512 MB
Screen size: 1280 x 800
Displays: Color LCD

USB devices
Apple Inc.: FaceTime HD Camera (Built-in)
Apple Computer, Inc.: IR Receiver
Apple Inc.: Bluetooth USB Host Controller
Apple Inc.: Apple Internal Keyboard / Trackpad
Logitech: USB Receiver

Bluetooth devices
None

OpenGL information

OpenGL software
OpenGL version: 2.1 APPLE-7.22.24
Render version: 2.1
Shading language: 1.20
Maximum texture size: 16384 x 16384
Z-buffer depth: 24 bits
Maximum viewport size: 16384 x 16384

Implementation settings
Use texture compression: No

Appearance settings
Antialiasing: 4x
Mip map filtering: None
Anisotropic filtering: None


#8

I have the same problem.

SOFTWARE
Rhino 2013-12-02 (492)
OS X 10.7 (11A511)

HARDWARE
Model Identifier: MacBookPro5,5
Processor Name: Intel Core 2 Duo
Processor Speed: 2.53 GHz
Memory: 4 GB


(Marlin Prowell) #9

@sashnash and @dumu , both of you have out of date versions of OS X 10.7. The last version is 10.7.5. I’d first suggest running Software Update multiple times until it tells you that everything is up to date. Then repeat the tests above.

To those adding posts that you have the same problem, you need to also perform all the tests that I outlined above and describe here what exactly happens before you can claim to have the same problem.

Also please post the full OpenGL settings from Rhino.


#10

Thanks. I have a studio final review in a couple days, so I’ve been busy, but I’ll go through this process once I’m finished with that to see if it helps. Thanks for all of your input so far.

  • dumu