Cursor Not Accurate Rhino 6

Hi Everyone,

I started noticing yesterday that my cursor is not selecting the item it’s pointing at. When I go to select an edge, for example, another edge behind or above/below will be selected instead. If I rotate and face the item I’m trying to select at a different angle the issue goes away most of the time.

I uninstalled and re-installed my graphics driver multiple times but it hasn’t seemed to help. I’m also not sure if this coincides with the last Rhino update I installed yesterday, but right now that’s all I can think of that may have contributed to the issue.I included an example of this happening when I’m trying to duplicate an edge as well as my system info below.

If anyone has any thoughts it would be a huge help. It’s next to impossible to model anything when I’m not sure what I’m clicking on will be selected.

Rhino 6 SR31 2020-11-10 (Rhino 6, 6.31.20315.17001, Git hash:master @ ff08c426b1ef7d3a1c50a01e5e87220a68a9f815)
License type: Commercial, build 2020-11-10
License details: Cloud Zoo. In use by: Justin Trudeau ()

Windows 10.0 SR0.0 or greater (Physical RAM: 64Gb)
Machine name: WINTERMUTE

Non-hybrid graphics.
Primary display and OpenGL: NVIDIA GeForce GTX TITAN X (NVidia) Memory: 12GB, Driver date: 9-24-2020 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 456.55

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 8x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 9-24-2020
Driver Version:
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 12 GB

Rhino plugins
C:\Program Files\Geometry Gym\Rhino3d\ggRhinoIFC.rhp “ggRhinoIFC”
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.31.20315.17001
C:\Program Files\Geometry Gym\Rhino3d\BullAnt.rhp “bullant”
C:\Program Files\Rhino 6\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Users\WINTERMUTE\AppData\Roaming\McNeel\Rhinoceros\6.0\Plug-ins\Iris (1cd9c8f5-c901-426c-8e80-d6a2e2b18bba)\1.0.7284.18297\Iris.WinR6.rhp “Iris”
C:\Program Files\Rhino 6\Plug-ins\RPC.rhp “RPC”
C:\Program Files\Rhino 6\Plug-ins\RhinoBonusTools.rhp “Rhino Bonus Tools”
C:\Program Files\Rhino 6\Plug-ins\RhinoLabsTools.rhp “Rhino Labs Tools”
C:\Program Files\Rhino 6\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.31.20315.17001
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.31.20315.17001
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.31.20315.17001
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino 6\Plug-ins\NamedPositions.rhp “Named Position”

  • Is your model a long way from the World coordinate origin?
  • Does picking work better in a Wireframe display?
  • Is the problem in all files or just this one?
  • Is your Windows running in a "recommended’ screen resolution and text scaling setting?

Hi John, thanks for helping. -

-The model is centered on 0,0,0 as well as other models that have the same issue.

  • The picking seems a little better with wireframe but it still happens sometimes so it’s hard to tell if this is true
    -The problem happens with multiple files
    -I just checked and windows is running at the recommended resolution

Here’s an example showing the issue in wireframe mode.


Another thing to check is your clicking radius.
If it’s too big for your current Zoom magnification, this can act like you described.
Zooming in closer or making the setting tighter can help.

1 Like

That’s what I initially thought too, so I changed the radius to 30 from 20. I’ll try to making the radius even smaller and see if that helps. The thing that I was odd - the pickbox size presumably hadn’t changed from when the mouse was picking out items correctly. Do you think it’s possible this value changed after an update and I wasn’t aware? Or I had multiple windows open and closed a window that default values last?

I’m going to reduce the pickbox size, work with the new setting for a bit and report back.

Thanks for the help so far.

@John_Brock, so far so good, I’m not sure how, but I think the pick box may have been enlarged, or simply making the radius smaller than default helped with the accuracy.

Thanks again for helping me fix the problem. If for some reason it creeps back up I’ll check the pick box settings, and if that doesn’t work I’ll pester you for advice again.