Cursor/pointer alignment off center

When in ‘top’ or ‘perspective’ view my selection cursor is not in the center of my crosshairs, I have to compensate by always clicking slightly to the left of the object I want to select. This get especially problematic when I am trying to click an object or surface that is close to or meets with other surfaces/objects.

The photo below shows my top view and what is happening, at times it is worse than other. Sometimes it is slightly off but sometimes it is off by an unmanageable amount .

I have been having this problem for more than 6 months, I have contacted Mcneel/Rhino support and they were not able to resolve this, anyone have any suggestions?

sorry. cross hairs dont show in the screen shot.

Hello - if the crosshairs are turned off, does the cursor look correct? Can you please run SystemInfo in Rhino and post the results?


Hi - No, if I turn off the cross hairs the pointer is still off center, it is a bit less confusing but still the same. I have to purposely click left of what I actually want to select. When selecting an object it will select to the right of where I am actually clicking.

How do I run the system info? I tried typing it in the command bar but it said ‘unknown command’


Hi Ian - that’s a new command in Rhino 6.
For Rhino 5, please take a screen shot of your Rhino Options > View > OpenGL page and post that here.

Hi Ian - please also tell us about your monitor size and the scaling used by Windows? (100%, 150% etc)


See screenshot below.

@wim - I am using a 17" dell laptop monitor and an ASUS 27" monitor. I assume I am on 100%. Aspect ratio on both is 1920x1080

Hi Ian - thanks, looks fine to me… does it make any difference if you unhook the external monitor?