Crash when use clippingplane in Rhino 8

when i use clippingplan in rhino 8, crash every time,
(it’s better when the model is very simple but that not general work…)
my window PC is new (i7 14700KF + RTX 4070Ti Super)
i changed the Graphics card driver
and try other version of rhino8 (like 8/8.1/8.2/8.3/8.4)but didn’t work.
but it works when I Change “OpenGL” in options from “Max OpenGL” to “OpenGL 3.3”
BUT, it’s slow and i don’t think it’s the best solution.
please help me .thanks!

Please run the Rhino command _SystemInfo and post the result in a reply.

Thanks! here is my result:

Rhino 8 SR4 2024-2-13 (Rhino 8, 8.4.24044.15001, Git hash:master @ 5d3f86ffffae3c2ed84d21147c008b3907a40a2e)
License type: Commercial, 版本2024-02-13
License details: Stand-Alone

Windows 10 (10.0.19045 SR0.0) or greater (Physical RAM: 64GB)
.NET 7.0.0

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: NVIDIA GeForce RTX 4070 Ti SUPER (NVidia) Memory: 16GB, Driver date: 2-7-2024 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 551.52
> Accelerated graphics device with 4 adapter port(s)
- Secondary monitor attached to adapter port #0
- Windows Main Display attached to adapter port #1

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 2-7-2024
Driver Version: 31.0.15.5152
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 16376 MB

Rhino plugins that do not ship with Rhino
E:\Program Files\Rhino\plugin\BlockEditNew\BlockEditNew.rhp “BlockEdit” 1.0.0.0
C:\Users\BX\AppData\Local\Programs\Enscape\Bin64\Enscape.Rhino8.Plugin.dll “Enscape.Rhino8.Plugin” 0.0.23328.1419
C:\Users\BX\AppData\Roaming\McNeel\Rhinoceros\8.0\Plug-ins\D5Conv (e0d5e210-02f6-4ee9-a2b0-1675e225d958)\0.12.0.0028\Rhino 8\D5Conv.rhp “D5 Sync for Rhino”

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 8\Plug-ins\Commands.rhp “Commands” 8.4.24044.15001
C:\Program Files\Rhino 8\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 8\Plug-ins\RhinoRenderCycles.rhp “Rhino 渲染” 8.4.24044.15001
C:\Program Files\Rhino 8\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 8.4.24044.15001
C:\Program Files\Rhino 8\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 8\Plug-ins\MeshCommands.rhp “MeshCommands” 8.4.24044.15001
C:\Program Files\Rhino 8\Plug-ins\RhinoCycles.rhp “RhinoCycles” 8.4.24044.15001
C:\Program Files\Rhino 8\Plug-ins\RhinoCode\RhinoCodePlugin.rhp “RhinoCodePlugin” 8.4.24044.15001
C:\Program Files\Rhino 8\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 8.4.24044.15001
C:\Program Files\Rhino 8\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 8\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino 8\Plug-ins\SectionTools.rhp “SectionTools”

You could try updating to the service release candidate for 8.5 (Tools > Options > Updates and Statistics, set update frequency to Service Release Candidate).

If that still doesn’t help try disabling the new block edit, enscape and d5 plugins. If it still keeps happening please make sure you send in crash reports, assuming the Rhino crash reported dialog pops up after a crash.

1 Like

Got it thanks! will try