Rhino 8 Lagging Freezing then Crashing When Clipping Planes are Enabled

So this is a pretty standard school file that I have been working on for architecture. I don’t think I’d even consider it very complex right now either. It’s only 56MB and it includes really simple topo and surrounding context buildings, but I keep all of them hidden while working. I was initially working in Rhino 7 and copied everything over to Rhino 8 because the new features would allow me to speed up my workflow. That was true until I started enabling clipping planes in plan and other standard views. I have a couple 2D drawings inside the file in question that I made using the Make2D command, but that was never an issue in my Rhino 7 file, where I had like 5 2D drawings all showing at the same time with hidden lines. So the problem is, when I enable a clipping plane in plan (or other views), my file immediately begins to lag, then it freezes, then it crashes or takes at least 20 minutes to unfreeze, all for it to just repeat that process when I pan again. All I’m trying to do is create 2D drawings to draw my ideas over and then model in 3D. Eventually, I clean up the file by deleting the 2D drawings and layers and repeat the process as I work. I feel like my file is somehow corrupted because of the crashes at this point. I have reduced my OpenGL settings and made sure my power settings were good for my computer. I even gave Rhino a High Priority status from my Task Manager. I’ve tried using the SelBadObjects to delete those, but it doesn’t select anything. I’m really confused at this point. Please help.

The file link: 20231124_DesignDev-08.2

System Info

Rhino 8 SR1 2023-11-21 (Rhino 8, 8.1.23325.13001, Git hash:master @ 8a4a437248efac5d9cb04d3904481b83e4c23a64)
License type: Evaluation, build 2023-11-21
License details: Cloud Zoo
Expires on: 2024-02-13

Windows 11 (10.0.22631 SR0.0) or greater (Physical RAM: 31Gb)
.NET 7.0.0

Computer platform: LAPTOP - Plugged in [100% battery remaining]

Hybrid graphics configuration.
Primary display: AMD Radeon™ Graphics (AMD) Memory: 1GB, Driver date: 9-28-2022 (M-D-Y).
> Integrated accelerated graphics device with 3 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port
- Secondary monitor attached to adapter port 1
Primary OpenGL: NVIDIA GeForce RTX 3080 Laptop GPU (NVidia) Memory: 16GB, Driver date: 10-26-2023 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 546.01
> Integrated accelerated graphics device with 4 adapter port(s)
- Video pass-through to primary display device

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 10-26-2023
Driver Version: 31.0.15.4601
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 16 GB

Rhino plugins that do not ship with Rhino
C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros\V7\VRayForRhino.rhp “V-Ray for Rhino”

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 8\Plug-ins\Commands.rhp “Commands” 8.1.23325.13001
C:\Program Files\Rhino 8\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 8\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 8\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 8.1.23325.13001
C:\Program Files\Rhino 8\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 8\Plug-ins\MeshCommands.rhp “MeshCommands” 8.1.23325.13001
C:\Program Files\Rhino 8\Plug-ins\RhinoCycles.rhp “RhinoCycles” 8.1.23325.13001
C:\Program Files\Rhino 8\Plug-ins\RhinoCode\RhinoCodePlugin.rhp “RhinoCodePlugin” 8.1.23325.13001
C:\Program Files\Rhino 8\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 8.1.23325.13001
C:\Program Files\Rhino 8\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 8\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino 8\Plug-ins\SectionTools.rhp “SectionTools”

Hi Jose - as a first test, please disable VRay in Options > Plug-ins page, then close and reopen Rhino. Does the behavior change?

-Pascal

I’ve tried that already, too. Unfortunately, no): I’ve tried many things already, thanks to chatGPT, this was my last resort.

Thanks, I see this here as well with your file.
RH-78611 Display - Massive lag with clipping plane

-Pascal

I’m wondering if it has to do with my blocks, or the fact that I imported the walls, floors and some of the doors from Revit. I exported the Revit file using DWG, as GPT described the settings that would be best. I just retried disabling the Vray plugin again to double check and yea it froze again. Let me know if you have any ideas, I’m willing to try any and everything at this point. I have tried copying to another file and opening the file in Safe Mode too. The safe mode seemed to work fine, but I never got down to which plugin was the problem because I disabled Vray and then did not want to disable any of the plugins that come standard with Rhino 8. Copying to another file in Rhino 8 did not solve the problem for me either.

Should I work in Rhino 7 until this is resolved? ):

Hi Jose - with this file at least, I don’t see a good alternative.

-Pascal

Darn it! Okay, I appreciate the help. Best of luck in resolving the issue!

@Jose_Moreno - it looks like some NVidia card/driver combinations are prone to this. You can make Rhino work a lot better with this file in V8 by un-checking ‘GPU Tessellation’ in Options > View > OpenGL page.

-Pascal

1 Like

Okay,thank you!

Hi again Pascal,
I tried turning off the GPU Tessellation as you said, and when I view that file from my Top view in Wireframe mode afterward it causes all 3D and line objects to disappear. The only thing that remains seems to be the section cut lines.

If this issue is with my NVIDIA card/driver combo, should I revert to a specific driver that works best with Rhino?

Hi Jose - I see … and I see you have a Radeon card, and not an NVidia… Iwas able to repeat the problem you reported right away, here, on my NVidia and the developers did not see it at all on their systems.

I don’t know what the answer is - you might try re-neabling GPU Tessellation and moving the OpenGL: slider to the left one notch… I am not super optimistic but worth a try.

-Pascal

Any discoveries here? Having the exact same issue with a relatively small size file which was working on RH7…

I ended up just creating a new file in R8 and only copying over the objects I was working on (walls, lines, and good blocks that I had). Anything that I suspected of being the problem (basically any meshes, clipping planes, or rough-looking blocks) I didn’t copy over. I created new blocks where I had to and new clipping planes too. No easy answer for this one, Claudio… sorry.

Hi Claudio -

Please run the Rhino SystemInfo command and copy-paste the result here.
-wim