Crash when attempting to change dim style


#1

Here are some details:
When trying to do this:


Rhino crashes. Multiple attempts on numerous files produces same result.
Suspect latest update as previous versions do not have this problem.


(Dan Belcher) #2

Hi Hugo-

Thanks for reporting this. Unfortunately, I’m unable to reproduce this on my computer. Here are the steps I’m taking:

  1. Launch Rhino for Mac 5.3.2 (I’m running on macOS Sierra 10.12.3)
  2. Start a new modeling window.
  3. Navigate to File > Settings… > Dimensions tab.
  4. Click the + (plus) button at the lower left-hand corner) to add a New Dimension Style.
  5. Selecting (built-in) Millimeter style and then click Create.

A new dimension style is created. Am I doing roughly the same thing you are? What am I missing?

Let’s see if we can figure this one out.

Thanks in advance,
-Dan


#3

Hello Dan,

Thank you for your response.

Firstly, this is what I am running:

Perhaps the 10.11 is the problem with the update? I am not a real expert here i’m afraid.

Whilst I am not totally certain, I suspect my problem has only been apparent since I loaded the last Rhino update (fairly recently).

Yes, by following your exact steps I get the same result - crash! However there are two iterations of the crash. One is where the whole program freezes and requires a ‘force quit’ from the apple menu in the top left corner. The other iteration is where the program (Rhino) just completely drops out.

I have made a quick time recording of my steps and the resultant crash and its here if you are able to download it: https://www.dropbox.com/s/4j9vmvvvkkih46x/Rhino%20Crash.mov?dl=0 https://www.dropbox.com/s/4j9vmvvvkkih46x/Rhino%20Crash.mov?dl=0

Kind regards,
Hugo Wansey.


(Dan Belcher) #5

Thanks Hugo. I’ll take a look on 10.11.6 and see if I can reproduce it there.


#6

Hello Dan,

Any joy on this problem? I really need it sorted if I can. I am down to doing the change on my PC educational version and then reopening the file in my mac version. It works, but is an inconvenient fix.

I am thinking of uninstalling rhino for mac and then reinstalling it.

I haven’t had an issue with any other app running on 10.11 yet, so I do still suspect the last rhino update. Can you give me access to the previous version?

Kind regards,
Hugo Wansey


#7

Hi @hwansey , you may want to block out your serial numbers. To be safe.
«Randy


#8

Had same problem. Sent in file but it can happen on s brand new file as well.


#9

Hello, my problem with Rhino 5.3.2 on Mac OSX 10.10.5 is that I cant get to the dialog box where you can edit settings of the dimensions (screen shot taken from another post);

If I select “Dimension Styles” from the Dimension menu, I get this:


#10

OUPS, more and more bugs working with dimensions; window freezes, tool palettes disappearing etc. Can I get a previous version?


#11

Just reverted to 5.2.4 and cannot get to modify the Dimensions settings. At least this version seems less buggy as I can see something in the Dimensions settings window… without being able to modify settings.


(Dan Belcher) #12

There is a little tiny circle on the right-hand side of the window. Please place your mouse over it and drag it to the left. Does that help?


(Dan Belcher) #13

Hi @hwansey-

Sorry, I’ve not had a chance yet to dig into this. I’ll try today.

In the meantime, which version did you want to roll back to?

-Dan


#14

Thanks Dan. That was the trick.


#15

I found 5.2.4. This is what I’m using right now.


#16

Hello Dan,

Let’s try the one previous.

I don’t always update at the initial prompt, but I do always update and the problem is only recent for me at least. Although I see that others are having problems in the same vein.

Kind regards,
Hugo Wansey.


(Dan Belcher) #17

Unfortunately, I did not make much headway on this today. It’s still on my radar.

In the meantime, you can roll back to:
Rhinoceros 5.3.1
Rhinoceros 5.3
or
Rhinoceros 5.2.4

I would be curious to hear what happens as I’m having trouble reproducing the issue on my end.


#18

Hello Dan,

I reinstalled 5.2.4.

Not sure whether this is good news or bad but - changing dim style works as advertised on 5.2.4!!

Kind regards,
Hugo Wansey.


(Dan Belcher) #19

Hi @hwansey-

Ok, I had more of a chance to look into this today. I was able to reproduce your issue with Rhino for Mac 5.3.2 (5D197) running on OS X 10.11.6. However, when I tested the current RhinoWIP (5E44w), I did not get the same behavior…it worked as expected. What does this mean? Well, I guess we must have changed something between 5.3.2 and today that fixed this bug when running on OS X 10.11.6. I’m not going to log this as a bug because this fix should go out in the 5.4 update. Since you are happily running on 5.2.4, I guess you are fine - that is - until you find a bug that we’ve fixed since then. That said: I guess you have a couple other options…

  • Update to macOS Sierra 10.12.3 (free and easy)
    or
  • Use the RhinoWIP (which can run on the same machine as the stable, commercial release) to add and change dimension styles
    or
  • Keep using 5.2.4 and wait until 5.4 is published (no ETA yet)

Thanks again for reporting this! Sorry for the trouble.

Best,
-Dan


#21

Hello Dan,
I appreciate your efforts and I still think it’s a great product.
As you point out, I have options to get past this bug.
Kind regards,
Hugo Wansey.