Crash upon creating new layout RH8

Using native Rhino Small - Inches Template, I can’t create a new Layout without it crashing Rhino 8.

And it doesn’t even orient properly as a landscape - comes in portrait and dies.

Thx

Alan

LayoutMakesRhinoCrash_AlanFarkas_240610.3dm (38.7 KB)

SysInfo

Rhino 8 SR8 2024-6-6 (Rhino 8, 8.8.24158.03001, Git hash:master @ c3cb4a9dc98ee25dc1f6e221e25c58a938d8d81a)
License type: Commercial, build 2024-06-06
License details: Cloud Zoo

Windows 11 (10.0.22631 SR0.0) or greater (Physical RAM: 32GB)
.NET 7.0.20

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: NVIDIA GeForce RTX 3060 (NVidia) Memory: 12GB, Driver date: 6-1-2024 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 555.99
> Accelerated graphics device with 4 adapter port(s)
- Windows Main Display attached to adapter port 0

Secondary graphics devices.
NVIDIA GeForce RTX 2070 (NVidia) Memory: 8GB, Driver date: 6-1-2024 (M-D-Y).
> Accelerated graphics device with 4 adapter port(s)
- Secondary monitor attached to adapter port 0

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 1.1

Anti-alias mode: 8x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: Not supported
Driver Date: 6-1-2024
Driver Version: 32.0.15.5599
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 12 GB

Rhino plugins that do not ship with Rhino
C:\ProgramData\McNeel\Rhinoceros\8.0\Plug-ins\Datasmith Rhino Exporter (d1fdc795-b334-4933-b680-088119cdc6bb)\DatasmithRhino8.rhp “Datasmith Exporter” 5.4.1.0
C:\Users\alanf\AppData\Roaming\McNeel\Rhinoceros\8.0\Plug-ins\BlockEditNew\BlockEditNew.rhp “BlockEdit” 1.0.0.0
C:\Users\alanf\AppData\Roaming\McNeel\Rhinoceros\packages\8.0\Garage\8.7.24140\net7.0\Garage.rhp “Garage” 8.7.24140.15431
C:\Users\alanf\AppData\Roaming\McNeel\Rhinoceros\packages\8.0\rhinopbrmaterial\1.1.4+v6.16\RhinoPbrMaterial.rhp “RhinoPbrMaterial” 1.1.2.0
C:\Users\alanf\AppData\Roaming\McNeel\Rhinoceros\packages\8.0\SubstanceImporter\2.0.7\Substance.Win.rhp “SubstanceImporter” 2.0.7.0

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 8\Plug-ins\Commands.rhp “Commands” 8.8.24158.3001
C:\Program Files\Rhino 8\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 8\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 8.8.24158.3001
C:\Program Files\Rhino 8\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 8.8.24158.3001
C:\Program Files\Rhino 8\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 8\Plug-ins\MeshCommands.rhp “MeshCommands” 8.8.24158.3001
C:\Program Files\Rhino 8\Plug-ins\RhinoCycles.rhp “RhinoCycles” 8.8.24158.3001
C:\Program Files\Rhino 8\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 8.8.24158.3001
C:\Program Files\Rhino 8\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 8\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino 8\Plug-ins\SectionTools.rhp “SectionTools”

Works here, please disable your plugins

Animation

This has been fixed in the most recent service release candidate

2 Likes