Crash during opening .3dm file saved in rhino6 - 6.18

Hi there,

rhino doesn’t open my file TNM144 - opzet.3dm (5.7 MB) . I have recently updated 6.17 => 6.18. How can I roll back to 6.17 on OSX?

best regards,
Tim

Opens here in Windows Rhino 6.19 Release candidate… there are 67 linked block definitions that are missing. Maybe Rhino is hanging trying to find one or more of those?

Hi, @Helvetosaur,
thanks for your reply. The file used to open in version 6.17, so I am just looking for a way to continue production for now.
If I can roll back to 6.17, I should be able to embed the linked blocks or make a list of all the linked files that might cause the issue.

best regards,

Dag Tim - you can download SR 17 from this link. Please let us know if that lets you open that file.
-wim

Dankjewel Wim,

I am very confused now.

I could open the file with SR17 from the link you send me. However, I noticed I was able to open in SR18 after I opened with SR17 first. I tried to set up a reproducible sequence of actions, however, after a few times opening and closing the file with both SR17/SR18 I couldn’t open anymore with SR17 either.

Could it be related to the search paths and some global application settings that are used by different rhino applications? Anyway i’ll keep trying to isolate the problem

Thanks for that, Tim.
Are both SR17 and SR18 consistently crashing on you now when you open your file?
Does Rhino leave any trace - crash reporter, error message, …?
-wim

Hi Wim,

“good” news: I created a file without linked blockdefinitions that I can no longer open with 6.17 or 6.18 afzuigkap.3dm (4.4 MB) .

I don’t see any crash report or error messages when trying to open it. The problems started when I tried adding a layer with rhinoscriptsyntax.

Best regards,

Hoi Tim,
the bad news is that this file opens without problems here on Mac 6.17 and 6.18.
Do you have any custom start-up scripts or plug-ins that might be getting in the way? Please run the Rhino SystemInfo command and post the result here.
-wim

Hi Wim,

see my system settings attached systemInfo.txt (2.5 KB)

I have cleared my “startupcommands” that I normally use to run custom startup scripts.

I have some new info:

  • I have a file that doesn’t open in rhino6.18 afzuigkap.3dm (4.4 MB)
  • I created a duplicate and tried opening in RhinoWIP(7.0.19253.12046). It did open as expected
  • I closed rhinoWip and reverted changes on exit
  • I tried opening the duplicate afzuigkap.3dm (4.4 MB) in rhino6.18 and it did open succesfully (N.B. the filename in the discourse fileupload changed from ‘testfile_kopie.3dm’ to ‘afzuigkap.3dm’, possibly because there are no differences in the file itself?)
  • the original file still does not open in rhino6
  • I created a duplicate of the duplicate, renamed to ‘testfile_kopie_kopie.3dm’. This file again did NOT open in 6.18

To me it seems the issue is related to a global setting that is used by different versions of Rhino, and the filesystem/filename.