.stl files keeps opening in previous Rhino version!

Hi I have a problem getting Rhino7 to open my (all other 3D files) as default.

When I open a .3dm file it works fine. it opens in the latest version Rhino7 also files made in a previous version 5 or 6 will get “upgraded” to the new version. and open fine.
And if I right clicking it I get the option to open in a previous version. all good :slight_smile:

But if i try to open a .stp .igs or .stl file it will always try to open it in r6. also right clicking and “open with” only gives me the r6 option.

Every time I need to go the long way of open with “Other…” and go search for rhino 7 and add it that way.

Checking the “always open with” dont make a difference.

.3dm files

.stl files

Hi John

Thanks for the link. I have tried both the Titanium/OnyX app and the command prompt reset and unfortunately i’m still stuck on only r6 on everything else but .3dm files :confused:

Don’t know if it was the order in which it was done that messed it up.

Changing “open with” in the “get info” fan dit not stick and keept reverting to r6.

Doing the “rebuilt LaunchServices database in OnyX” also ditten change any thing. it was still on r6.

but after the hard reset in command prompt i can now Changing “open with” in the “get info” and it sticks to r7

So it works now. but not sure why. maybe there was a bad file in the LaunchServices database that godt cleared after the hard reset. though OnyX should in theory be doing the same thing.

Anyways it works. so thanks for the help :slight_smile: