Contour Issue


#1

Hi, I’m trying to contour the attached simple surface in the z direction (spacing of 3mm). The contour command duplicates the border of the surface but doesn’t make any other curves. I was originally trying to do this in Grasshopper, but it also doesn’t work in Rhino, so I assume the problem lies there. Thank you, Steven

Contour.3dm (68.8 KB)


#2

yeah, maybe buggy?

if i select everything and rotate it a little, the command works.


#3

@chuck Definitely buggy. The Contour command periodically has this sort of problem. In this case it looks like the fact that the surface is degree 2 in each direction that seems to throw off the intersector. Even intersecting the surface with planes spaced at 3mm misses several of the intersections.

If you rebuild the surface to degree 3 in each direction, it works.

–Mitch


(Chuck Welsh) #4

You can also get it to work by adding a knot to the surface. I know this problem has been worked on recently. I guess it needs a little more. I’ll add it to the bug list.

Chuck


#5

Thanks everyone, I tried using the “ChangeDegree” command, but this doesn’t work because there are only 3 control points in each direction. Rebuilding is the same, so you have to increase the control points as well, which I don’t want to do, because it pushes the surface out of tolerance. In the meantime, I’m rotating slightly and contouring then rotating back. I’ve set this up in GH, but it’s pretty annoying because you have to try a bunch of different rotation angles before it actually works with all of the intersections.

Steven


#6

If you insert a knot in each direction (say, at the midpoint) as Chuck said, then it works, and doesn’t change the surface at all…

–Mitch