Components missing when installing plugins

Hello!
When installing plugins I have started to encounter problems with certain components not being installed. Reinstalling and installing through packagemanager/food4rhino does not resolve the issue. At the moment the plugins i’ve had issues with are Elefront and Ladybug. Below are images from my gh interface compared to gh-docs, to show whats missing.
Elefront:
image
image

Ladybug:
Only “falseStartToggle” missing

Any help would be greatly appreciated!

Hi,

what Rhino, GH version and windows you are using?

Hi thanks for the reply Im running Rhino 7, Win 11 and Gh 1.0.0007

Below you can find my Rhino systeminfo:

*Rhino 7 SR32 2023-8-9 (Rhino 7, 7.32.23221.10241, Git hash:master @ 3d9c816c4cd57561d12d8f53246bce304f314ba2)
License type: Educational Lab License, build 2023-08-09
License details: LAN Zoo Network Node

Windows 11 (10.0.22000 SR0.0) or greater (Physical RAM: 16Gb)

Computer platform: LAPTOP - Unplugged [78% battery remaining] ~40 minutes left

Hybrid graphics configuration.
Primary display: Intel(R) UHD Graphics 630 (Intel) Memory: 1GB, Driver date: 2-18-2022 (M-D-Y).
> Integrated graphics device with 3 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port
Primary OpenGL: NVIDIA GeForce GTX 1650 (NVidia) Memory: 4GB, Driver date: 10-25-2022 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 526.47
> Integrated accelerated graphics device (shares primary device ports)
- Video pass-through to primary display device

Secondary graphics devices.
Citrix Indirect Display Adapter (Citrix Systems Inc.) Memory: 0MB, Driver date: 1-23-2019 (M-D-Y).
> External USB display device with 8 adapter port(s)
- There are no monitors attached to this device. Laptop lid is probably closed

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 10-25-2022
Driver Version: 31.0.15.2647
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 4 GB

Rhino plugins that do not ship with Rhino
C:\Program Files\Rhino 6\Plug-ins\Karamba\License\Karamba3D_LicensePlugin_Rhino6.rhp “Karamba3DLicense”
C:\ProgramData\McNeel\Rhinoceros\7.0\Plug-ins\Twinmotion Direct Link 2020.2 (e24ee14a-9514-47da-8fe6-f6e61b20160e)\Twinmotion Direct Link 2020.rhp “Twinmotion Direct Link 2020” 1.0.6.0
C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros\V6\VRayForRhino.rhp “V-Ray for Rhino”

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.32.23221.10241
C:\Program Files\Rhino 7\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 7\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.32.23221.10241
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.32.23221.10241
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Users\oskar\AppData\Roaming\McNeel\Rhinoceros\7.0\Plug-ins\PanelingTools (6caed836-bc06-4ebc-b1fd-e10886a0dc94)\2018.12.17.906\PanelingTools.rhp “PanelingTools”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\Alerter.rhp “Alerter”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.32.23221.10241
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.32.23221.10241
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

Hmmm. I am not sure what is happening there. those are rather standard settings.

I presume that:

1)You have enabled all grasshopper components.

2)You have toggled this little guy.

Hi Oskar -

Are you absolutely sure you are comparing the same versions of the plug-ins?
-wim

Yes its toggled, im not sure what you mean by “enabled all grasshopper components” I havent manually disabled anything if thats what you’re asking :slight_smile:

Yes compared it to a friends plugin on another computer, same version and everything :slight_smile:

Hi Oskar -
Apparently, you can find the falseStartToggle here:

I’m moving this thread to the Elefront category so that, perhaps, someone who’s familiar with that plug-in knows more.
-wim

Hi @Oskar_Johannes are there any popups or dialogs when you load Grasshopper? I would also go into GrasshopperDeveloperSettings and set the options at the top about loading using COFF arrays to “true”.