No plugins in GH?

I dont know what I am doing wrong but I dont seams to be able to load any plugins in GH… And I even try to get the “old” tabs back but dont know how.
For instance I have installed PanelingTools but cant get the def up even in the search box… It is visible in Rhino though.
Any help would be appreciated!

Hi Per -

When you move your mouse in the area between the category headers (“Geometry”, “Primitive”, “Input”, etc.), the area in light gray should turn darker and the mouse pointer should change. You can then pull down the divider line and the components should become visible.

Apart from that, which version of Rhino are you running? Please run the Rhino SystemInfo command and copy-paste the result here.

Hi Wim
I have the latest service release candidate
Version 7 SR10
(7.10.21244.1001, 2021-09-01)

System info:
Rhino 7 SR10 2021-9-1 (Rhino 7, 7.10.21244.01001, Git hash:master @ 414ed9bf00ad65e22f2b63aa447c55cbbc8e233a)
License type: Commercial, build 2021-09-01
License details: Cloud Zoo

Windows 10.0.19042 SR0.0 or greater (Physical RAM: 16Gb)

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: NVIDIA GeForce GTX 1060 6GB (NVidia) Memory: 6GB, Driver date: 6-21-2021 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 471.11
> Accelerated graphics device with 4 adapter port(s)
- Windows Main Display attached to adapter port #0

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 6-21-2021
Driver Version:
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 6 GB

Rhino plugins that do not ship with Rhino
C:\Users\PP\AppData\Roaming\McNeel\Rhinoceros\6.0\Plug-ins\Thea For Rhino (0ab51401-0ca2-45e3-94e0-46d77b129353)\2018.3.18.0\Thea_V2\TheaForRhino.rhp “Thea For Rhino”

C:\Users\PP\AppData\Roaming\McNeel\Rhinoceros\7.0\Plug-ins\BoltGen.rhp “BoltGen”

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.10.21244.1001
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.10.21244.1001
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.10.21244.1001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\IronPython\RhinoDLR_Python.rhp “IronPython” 7.10.21244.1001
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.10.21244.1001
C:\Program Files\Rhino 7\Plug-ins\Grasshopper\GrasshopperPlugin.rhp “Grasshopper” 7.10.21244.1001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.10.21244.1001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino 7\Plug-ins\Calc.rhp “Calc”
C:\Users\PP\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\PanelingTools\2021.3.2.446\PanelingTools.rhp “PanelingTools”

Thanks for that, Per.

Can you expand the components toolbar by pulling down the divider?

Yes, Thank you that did work! But I have a number of plugins in Rh 6 but almost none of them show up in V7

Is that screenshot from Rhino 6 whereas the one in the first post is from Rhino 7?
That first screenshot doesn’t even show all factory-default tabs…
Since Grasshopper is a standard part of Rhino, I would try a repair of the installation through the Windows Control Panel and see if that clears things up.

Sorry for late answer got stuck in a meeting… Yes, you are so right (sorry for that to;-) the first screen-dump is from V7 and second from V6. And tried the repair from “Apps & features” in setting Win10 but no luck, same lack of plugins! The strange thing is when I open GH I can see that its loading the plugins in the progress-bar off GH.

And when you open an existing file with components from the plug-ins that do not appear on the menu bar, you can’t see the graph on the canvas but you can see a preview in the Rhino viewport? Did I get that part right?

Yeah, sort of… I opened a crystallon file and I could open it, and I can search for crystallon and get the components but it also contained a dendro component and that one opened but when trying to search for dendro it don´t show in the search bar, nor does millipede or pufferfish (for instance)…

I was wrong! I can search for the components and get them (it seams, only tried a few) but I cant view them in the menu bar. And I have ticked the box “show obscure components”…
And I can see them on the canvas!

Also in the preferences in GH under “Solver” I can see the plugins in “Plug-in Loading”

Is there someone the could shed a light over this matter? It seams that it is some setting in GH that don´t make it possible to show the plug-ins menus in the menu-bar… But I dont know what!
Any input, ideas?

Could maybe @DavidRutten pitch in, I am all lost?

Hi Per -

It sounds like you have several none-default plug-ins.
I would try the GrasshopperLoadOneByOne command and not load any 3rd party plug-ins. If that makes all default components display on the menu, it’s one of those others that is somehow blocking something.

Thank you Wim! I started doing that, but are there any other way doing that because I have to close GH and Rhino for every plug-in that I choose to load and what not to load?
There is some that has shown up but I don´t know which is default and which is not.

Cant I do it with the solver? disable all to load and then enable them one by one?
Edit: Nope that didn´t work…

I must Thank you so much @wim for hanging in there and helping me!!
I found the malfunctioning component, it was the “20151210_YANG.gha”
So now I got all my plugins back! :sweat_smile:

I owe you a large cold beer!

1 Like