Command Prompt is gone


#1

My command prompt is gone please help.


#2

Go to Options>Appearance and check “Command Prompt”…

HTH, --Mitch


(Other Bruce) #3

My command prompt goes missing regularly - your help taught me the above, but it happens often enough that I’d like to make a button to turn it’s display back on. Unfortunately, turning it back on leaves no history in the command box. So, I don’t know what would that button’s code should be. Does anyone? TIA- OB


(Pascal Golay) #4

Hello - this is certainly wrong… does this happen every time you start Rhino? Or does it happen somehow in the session as you are working?

You can get it back on the fly by typing, in space as it were, CommandPrompt Show=Yes

-Pascal


(Other Bruce) #5

I have not discovered what trips it. It happens in brand new sessions, as well as old drawings.
I’m assume that I invite the problem because I float it like any other toolbar (wearing cheater glasses at the bottom of my nose make it hard to look way up all the time). ScreenSHot


(Pascal Golay) #6

Hello - try docking the prompt at the very bottom - does that work better?

-Pascal


(Other Bruce) #7

Docking takes additional Real Estate as it jumps to full width. I am not verbose enough to need that much runway, and I like the space for geometry.
Thank you for the “CommandPrompt Show=Yes” that will be a great workaround, as I suspect this is pretty low on the list of ‘wants’ for development team.


(Nathan 'jesterKing' Letwory) #8

You could dock the command line next to the osnaps bar:

If you need to see the output of the command-line you can always use F2 to see the command history.

If you run a command with lots of options it will still be drawn in such a way that you can see them all, here an example with _RhinoCycles_SetAdvancedOptions:

To dock in that corner drag the command-line all the way to the right of the osnap toolbar:

image


(Other Bruce) #9

Excellent! Many thanks! It took me a while to figure out that I had to add the snap toolbar to the docked Command toolbar to make it work. Step by step I am losing my excuses for not being productive.