Command bar not dockable after _FullScreen

Today I dared to try _FullScreen.
The toolbars are visible in this mode, which is not right.
I hoped this was solved.

But that’s not the main problem:
After ESC, I got a different layout than before:

Ok, I arrange it manually.
I didn’t manage to move and snap the command bar.
It just doesn’t snap.
Also it doesn’t show the … handle grip?

Please explain how to get the command bar to the top again.

Of course I tried to place the command bar first, which works.
But then I can’t place the toolbars.

What is the blue frame in the command bar?
Sometimes it becomes white, but the blue comes back.

The scrollbars are grey.

Regarding the docking, I know finally understood how it works…
I need to touch one of the blue rectangles with the MOUSE, then the prospective position becomes a large blue rectangle.

I didn’t expect that.
In V7 the docking is more obvious.

Why so complicated in V8?

Yes, the “discoverability” of the new system is obviously much poorer than the previous version.

As I understand it, these new smaller “targets” were the best compromise so the menu tools would work in BOTH Windows and Mac Rhino.
Once you have seen it, they work well IMO.
But I agree, they are a little confusing the first time you see them.

Yes, once understood, it works.
Nevertheless it’s a regression.

I wonder why the small targets are needed for Mac.
Some people say that Mac is so super user friendly …?

Perhaps the normal drop preview can be implemented on Mac as well?
I can’t imagine an Apple PC is not able to draw large blue rectangles.

It’s possible they’re running into ETO limitations, rather than Apple limitations… Just a guess though.

That’s a reasonable guess to me too.
I’m not involved in those discussions and decisions so no first-hand information.

ETO = Extra Tough Obstacles :laughing: