Clipping planes in Raytraced mode


#1

Feel free to move this to the right sub topic or a different thread. It’s about Cycles and clipping planes in yesterday’s WIP.

2 strange behaviors:
In the right viewport when switching from any other display mode to raytracing the piece of the clipped object which is shown switches from one side of the clipping planer for all but raytraced to the opposite one for raytraced.
In the perspective viewport the clipped edge shows at the start, but as soon as cycles gets to work the whole object is shown and the clip section is either masked or disappears.


Cycles for Rhino renders only grey
(Nathan 'jesterKing' Letwory) #2

I am not sure if I understand your description correctly. Could you add some screenshots to show what you mean?

/Nathan


#4

Maybe I was too wordy. It’s not that complicated. Picture a side view of an object in the Right viewport split in the middle by a vertical clipping plane that you see edgewise. For all views except raytraced the left side of the object shows. Change to raytraced and the left side disappears and the right side shows. In other words the part of the object which is clipped off flips from one side of the clipping plane for raytraced view and the other side for every other view.

I need to go back and check that the perspective view even has clipping enabled.


#5

@nathanletwory I’ve attached a file which should give you plenty of things to entertain you. It’s a cone and a clipping plane. Just slide the plane back and forth and change between view modes.
In addition to the clipping plane/raytraced issues, there seems to be a new problem with my custom shaded and rendered no-grid modes, which worked fine before this WIP. Some kind of white-background grid is showing up when it should just be grey. Do you see any of this?

@stevebaer Another non-view mode issue also appeared: I created this test model starting as new, then “saved as”. The command line showed successful write and the file certainly ended up where I put it. The problem is that the new filename did not appear in the Rhino title bar at the top as it usually does and when I went to close Rhino using the Windows red X I got a message box which said that I made changes to “Untitled” and did I want to save them. I said “No”, Rhino closed and the file, as I said, was right where I put it with the name I assigned.

Raytraced Clip Plane Test 5-9-17 WIP.3dm (36.5 KB)


(Wim Dekeyser) #6

Around there, Rhino crashes as soon as I start moving that clipping plane.


(Steve Baer) #7

@pascal is this a known bug?


#8

@nathanletwory This file causes Rhino WIP 6-6-17 to crash upon loading it when chosen from the initial recents menu.


(Nathan 'jesterKing' Letwory) #9

Hmm, I don’t get a crash here. Have you tried setting your render device to CPU and see if that works better (in case something goes wrong in the GPU rendering part).

/Nathan


#10

OK. I tried using device 0 (CPU) and got the same thing. I quit Rhino and restarted it and loaded the file from the recently used list on the file menu.It appeared to load and display OK, but when I quit Rhino I got the crash. I will send you the dump.3dm separately to Pascal to forward, since I’m not sure of your e-mail.

When I set the device back to the K4000 it repeated the crash on read. (Actually, the command line reported the read was successful, but as Cycles was starting to render it crashed right after showing the clipping plane, but before rendering the cone.


(Nathan 'jesterKing' Letwory) #11

You can upload files with rhino3d.com/upload, use nathan@mcneel.com as recipient address.