9-12 WIP Cycles clipping planes not clipping

unhandled

#1

@nathanletwory
Generally, Cycles seems to do everything it should with a clipping plane the same as other display modes EXCEPT actually clipping. The clipping plane shows as does the clipped edge, but the part of the object that’s supposed to be clipped off is still there; won’t disappear.

In addition, it’s still awkward to turn the clipping on and off. This really needs some developer love as discussed in another thread.


(Nathan 'jesterKing' Letwory) #2

Clipping plane support for Cycles has been moved behind a test command TestToggleRaytracedClippingPlanes, which toggles the state of advanced flag RaytracedClippingPlanes. At some point during the 6.x cycle I’ll work on it again, but not necessarily for 6.0. Note that clipping planes are somewhat unstable in that they can cause the machine to hang, especially when tweaked while a Raytraced session is running.


(Wim Dekeyser) #3

Hi Nathan,
That doesn’t seem to be working here…

These are my modified advanced settings for RhinoCycles:
image


(Nathan 'jesterKing' Letwory) #4

Did you (re-)start the Raytraced viewport after making the change?

Btw, you should run TestCleanupRhinoCyclesSettings. There are no lower-case settings in latest WIP anymore.


(Wim Dekeyser) #5

I’ve now shut-down all Rhino sessions and started a new session. Clipping planes is still turned on:
image

But the result is the same:

Thanks for the clean-up tip. I’m worried how much other old stuff is laying around that made its way into my current WIP (daily 6.0.17256.14301, 2017-09-13) from RH5 and all the previous WIPs…


(Nathan 'jesterKing' Letwory) #6

Can you please share the model with me @ nathan@mcneel.com ?

I just tested current public WIP, and with simple box + clipping plane it Just Works.


(Wim Dekeyser) #7

I was just about to post that model when I thought I’d turn on the layer with the ClippingPlane on it. When I did, Cycles clipped the view correctly. Could you make it Just Work with hidden CPs as well? :innocent: =)


(Nathan 'jesterKing' Letwory) #8

If it is on a hidden layer I probably never even receive information about it through the ChangeQueue mechanism.


(Wim Dekeyser) #9

I’m not sure if you are saying that you can - eventually (6.x) - make this work correctly or not.
All the other display modes are doing this as they should…


(Nathan 'jesterKing' Letwory) #10

I’m only saying that currently I probably don’t get information from the ChangeQueue, but I haven’t really investigated. Mostly because for 6.0 probably ClippingPlanes will still be behind a test command, but 6.x should be feasible. I created RH-41390 to track the issue.

BTW, remember that with the experimental raytraced clipping plane support turned on you can also ‘tag’ objects with TestToggleIsClippingObject to be clipping objects, right?

(sphere selected, then run the command, then switch to Raytraced).

(or with a cube).


(Wim Dekeyser) #11

Thanks for reminding me!

From our May 12th conversation:

Behind-the-scenes trivial indeed.

I never did get a hold of that test command though! This is cool…
Thanks!


#12

I can confirm clipping planes still don’t work properly for raytraced modes in the shipped Rhino 6 (v Feb 6):

Shaded:

Shaded with clipping plane - all is fine:

Raytraced:

Raytraced with _TesttoggleRayTracedClippingPlanes run before. A white box appears:

Would be great to see this fixed! Many thanks!


(Nathan 'jesterKing' Letwory) #13

ClippingPlanes will be a supported feature in Rhino 7 - original clipping planes implementation was very crash prone, so it was decided to not ship with Rhino 6.


(Gilberto P 94) #14

Hi there,

I can’t make this work for some reasons… rhino says ‘‘The clipping object status for is now True’’ but nothing actually changes I can see the cube that i want to use as a clipping object.
I think this feature would be very useful, maybe I am missing a step?
also I am having the same problem with clipping plane in raytraced viewport and when I use the command ‘‘TestToggleRaytracedClippingPlanes’’ now instead of showing the part of the model that should be clipped, together with the clipping lines I basically only see clipping lines on a white background (no model, no shadows, no textrures, just lines in raytraced viewport)

Thank you.


(Nathan 'jesterKing' Letwory) #15

Indeed clipping planes don’t work yet. I restarted work on them yesterday.


(Gilberto P 94) #16

what about the TestToggleIsClippingObject? how do you make that work?
I tried to hide the object but it doesnt work that way…
do you literally just select the object, run the command and change viewport?
is the clipping object suppose to ‘‘desappear’’ and clip right away or am I missing a step?


(Nathan 'jesterKing' Letwory) #17

No, you are not missing a step, but the problem is more that the clipping code is currently non-functional. I hope to get it back up and running during the weekend and begin of next week. It’ll be a week or two before these changes end up in a public build.


(Nathan 'jesterKing' Letwory) #18

FWIW the current builds have the clipping plane support disabled because it caused hard crashes, sometimes locking of the computer.


(Gilberto P 94) #19

Ok thank you for that clarification.
Since you said that you will work on it soon there is another issue that I have encountered with the clipping plane.
I find very useful how snapshots allow us to make an animation in few minutes. Although I have realized that snapshots do not remember the position of a clipping plane.
It would be very useful to be able to move the clipping plane, save multiple snapshots and make an animation of an object being gradually cut to show its interior and how its made.
Assuming that i didn’t do something wrong and that it is actually already doable.


(Nathan 'jesterKing' Letwory) #20

The location and orientation of the clipping planes aren’t currently animated. I have logged a feature request here RH-45690.