Clipping plane lagging the layout page

I have this problem for a while now. As I am searching for any similar post I think this could be just me. I updated my GPU driver and disable the Vray plugin but the problem remains.

My day to day require me having to move quickly on sections. If I have too many (6.7.8+) clipping planes and each clipping planes show it’s own detail on my layout page, meaning having 6.7.8+ details on one layout page, the layout page becomes laggy. It takes 1 sec for me to wait for Rhino to react to a simple right-mouse-click pan on the page. The file is only 300m. Is there any setting I missed checking? Thanks in advance.

Hello - can you try testDisableAllClippingPlanes / testEnableAllClippingPlanes and see if that indeed toggles the performance problem?


Hi Pascal! I tried both and both have 0 clipping planes disabled/enable. I also tried to make all my details wireframe instead of Arctic but the lagging remains. Thanks

What are you running for a graphics card?
How much VRAM does it have?
How many monitors are you running and at what resolution?

Hi John, I am running a GeForce RTX 2060 video memory 6144m on my MSI GS65. Output mini display to one monitor resolution 3840 x 2160. Normally using both laptop and monitor when running Rhino 6. WIP runs better with the same file but I can still feel the lag.

With 6GB VRAM, you only have enough for one standard resolution monitor.
To drive 2, the minimum VRAM recommendation is 8GB VRAM.

If you temporarily switch to a single monitor, is the lag reduced?

I tried to unplug my mini display and see if it works better on my MSI. It’s still laggy but good to know for my future hardware upgrade. I have another file which is similar in file size but less clipping planes and less detail on layout pages works better. The lag is tolerable.

I changed the res down to standard and it works! The lag time is way less. Guess I will get a more powerful graphics card next time. Thanks John