Wish: Add an option for bad objects to stop reporting that they are bad

I have the ! _CheckNewObjects command active all the time, however, it’s very disturbing that I can’t stop reporting for certain bad objects that I want to be ignored for any future checks, while the rest geometry is still being checked by that command. I don’t want to lose the ability to be notified for newly created bad objects, while I’m aware for the bad nature of some already existing bad object that I don’t want to be a reason for Rhino to constantly show a pop-up window to warn me every time I move it somewhere in the 3d space. I know that I can turn off that notification, but then I will lose the possibility to be warned for newly created bad objects.

Hi Bobi - Yeah, the thing shouts every time a bad object tis added to the document- in reality, behind the scenes, that happens all the time to any object. If you move an object, in the code, a new object is added to the document at the new location. I don’t know if it is feasible to keep a list of bad UUIDs that will not be repeated, or something, but I’ll add this to the pile.


1 Like

Thank you, Pascal! That would really help, because currently I have two alternatives:

  1. Turn off the warming for checking bad objects entirely.
  2. Keep being spammed by Rhino gazillion times for the same bad object whose structure is not modified other than being moved.

Maybe if the object properties include a “Report bad object” Yes/No toggle to ignore a specific object based on user preference, then this will fix the inconvenience that comes with the warning pop-up window for that particular object every single time.

hi @Rhino_Bulgaria see if CheckBadObjects on _PackageManager helps.

1 Like

I installed it, but can’t find a way to use it. Running the “CheckBadObjects” command simply turns on Rhino’s default tool. Is there something I don’t do right? :slight_smile:

AFAIK there is no native CheckBadObjects, only SelBadObjects and CheckNewObjects, ? After installing my own plugin here it works…

did you restart Rhino after installing?

Yes, I did restart my Rhino 7. After I start Rhino again, upon moving a bad object a pop-up window appears asking me if I want to turn off the checking for bad objects for the current session only.

yes, you should turn off Rhino’s CheckNewObjects and use CheckBadObjects instead…
To test how it works you can _TestMakeBadObject

1 Like

Got it. It was in a conflict with Rhino’s own tool to check back objects. Now I only use your plugin. :slight_smile: Thanks! “McNee” should include that as a default behaviour in the future Rhino releases to make the work so much more convenient to Rhino users.

1 Like