STEP import dialog box for "bad objects" cannot be suppressed


I’m having an issue when importing step files, I cannot disable the import dialog box for bad objects and so i get a popup box on hundreds of files. I have a fix for the error geometry but I’m wondering if there is a way to turn this off.

I have tried the “-_CheckNewObjects _Check=_No _Enter” macro and went over the discussion on a similar mac problem here.


I have also uploaded a stp. we tried this on another computer and encountered the same problem. I’m not sure if this is a build in feature or a bug.


INT-C09-P07.stp (78.4 KB)

Hi Nathan - I do not get this warning here even with checking turned on… are you importing or opening?


Hey Pascal, thank you for looking into it. oh no, this is unfortunate… i did not check the STP import settings. i had it set to flag bad objects.


Thank you for looking into this. it was driving me crazy.

Heh… if I ever noticed that setting, I had completely forgotten about it… I’m glad it’s sorted.