Changing Units from Meter to Centimeter

You need to change the unit system of your file after the fact. In settings you change it from meter to centimeter and hit OK.

“Do you want to scale the model area by 100?”

I don’t know, I just want to display measurements in centimeter instead of meter. Why is this complicated, and will it ever become frictionless?

Thanks :slight_smile:

It’s asking if you want to scale the model so that its size is constant, or just treat 1 unit as a centimetre instead of a meter, changing its “actual” size. People need to do either, it has to ask.

If you want to just view measurements in different units, you don’t need to actually change the units of the file.

1 Like

Note, if dimensions are the thing you need to change, you can set dimensions to use whatever units you like - they do not need to be the same as the model units. You can also set them to display in two units.


1 Like

Sounds like there is a difference between units (the number I type to set a length with “line” command, or to measure with “distance” command), and the dimension commands?

I’m referring to the units used for modelling and interacting with the model, so that I can type 1 (cm) instead of 0.01 (m), at a certain stage in the process. This is really helpful for architecture, where you start out drawing 500 meter lines, and end up with 2 mm lines.

I see some people use millimeter all the way, having to type 5000000 (mm) instead of 500 (m), this can get very confusing, having to count the number of “0”, or “0.”


if you specify the units in the command line, Rhino converts the units for you.
e.g. if your document units are inches, but you want to create a 5mm-radius circle, when the command line asks for a radius, you can type 5mm and hit enter

1 Like

That’s actually a nice workaround! Will try that, thank you :slight_smile:

That’s not a workaround it’s a pretty basic CAD feature these days. Actually rescaling your model every time you want to use a different unit is not a great idea. Numbers are stored in base-2 not base-10, and after…uh possibly hundreds of years…the conversion errors will eventually stack up to something you might possibly notice.

Yeah, it seems like there should be possible to ask Rhino, please read my input as centimeter from now on. Instead of scaling blah blah, or typing explicit 5mm 5cm 5m every time… But I don’t know, I’m not a rocket scientist

That’s a ‘modality’ that would lead to user errors.

A problem with changing it for the commandline, is that this is not the only place where you enter numbers – e.g. you can say that “5” should switch to meaning 5cm in the commandline, but what about in obj props > edge softening? Ok, so we modify the request to apply to the commandline and also all numeric inputs. But what about numeric inputs in plugins? Not going to happen.

So the result, in practice, is that you end up in a twilight zone where you have to magically know which boxes take which style of input. Or, you say it is strictly a command-line thing, where the meaning of numbers is consistent, but ambiguous by design, depending if you are on the commandline, or not.

But you avoid this by saying, the commandline is prepared to parse units on the fly, and leave it at that.

1 Like

If you are going to work primarily using cm as the units then change the model to cm as the base unit.

If you want to use several different unit types then get in the habit of typing the unit after the number.


One thing is I always forget what the prompt means, lol even after years of using Rhino. I know we discussed this to death in another thread but the prompt is something cyrptic I just try one option and then find Oh wait I want to leave it the same size in the new units not scale it.
I’ve been doing odd scaling a lot because the Fx files I have are sometimes in cm or unitless or meters or inches. I found one workaround is to always in every file have a scaled model I use a cheap mesh or a man in Vitruvian height at six feet. It just saved me where I had tons of model going into unreal from a Rhino unitless file that came in gigantic at first. Lucky I had that man measure model to scale all against.

1 Like

I tend to think I’d just have it change the units without scaling, and that’s it – it’s not so confusing to me as it is startling/disorienting, having this question abruptly asked of me, where I have to process what it means, and decide, before being allowed to proceed. When the model is heavy, and scaling may take a long time to do, and then possibly undo, the inclination to just hit Cancel and think about it for a minute is strong.

Without the dialog, If I’m just correcting to match some .obj I started from, job done, and if not, it is gonna become apparent to me pretty quick that I need to scale my model.

1 Like

How can I achieve this, do you save an empty file with the cheap mesh as a template file? Or is there some other witchery involved :open_mouth:

Hi @julian.riise
No witchery I don’t have a template but you could do that.
I have a human body mesh grouped with a line running vertically that I have saved in a file at world 0,0,0. His size and the line is 6 feet, they reside on one particular layer so I know in any file at a glance what they are, I just import the file when I begin a project. I’m see most modelers import a body mesh to check things against otherwise I’ve found one can run into profound errors in scale.

1 Like