Rhino has suddenly defaulted to Units instead of Millimetres. Help!


#1

Hi everyone,
I have been using Rhino since it was a beta on the mac and I love it. I draw in millimetres.
I am using Rhino 5.3.2
As of a few days ago I have a problem. Rhino has always used millimetres by default.
Now when I open a new drawing, the default unit of measurement is shown in the bottom right hand corner as ‘Units’. I don’t know why and there appears no way to change it.
When I open a drawing i made in millimetres six months ago, it comes up as 'Units’
If I make a new drawing using the template ‘Millimetres’ and save it to my desktop. the next time I open it it is displayed as ‘Units’ and the dimensions are all over the place. I don’t know if I have inadvertently changed a setting or if this is the result of an update.
I would like to return rhino to its default of millimetres.
Any ideas ?
Simon :^)


#2

draw a line.

use the Length command on it…

what does it report as length?


fwiw, i model in Inches and some of my .3dm files say ‘Inches’ down there and some say ‘Units’ as you’re describing.

i’ve never noticed this before but as far as i can gather, if it says ‘units’ ,the file is still using whatever you have selected in File->Settings->Units.

like, i’ll send stuff out to CNC from a file that say Units at lower-right and the cuts are made precisely to inches.


#3

Thanks Jeff,
I opened Rhino, new drawing no template and the default is now “Centimetres” (?)

I drew a line, clicking once to start it and then entering ‘10’ in the command bar. Selecting linear dimension it’s length is shown as 10.

if I go to file/settings/units I can change the model units to millimetres and when I do I am asked If I want to scale the model up. I select ‘No’ so the model size has not changed from ten centimetres. I then save this drawing as a .dxf and close Rhino.

I open Rhino and open the .dxf from my desktop and it comes up in ‘Units’ and the drawing is dimensioned to a tolerance of 1.0000. and ten times bigger than it should be.

I can no longer save a drawing in ‘mm’ as it comes back in ‘units’ and all my dimensions are changed.

Any thoughts gratefully received,

Simon :^)


#4

again, just to verify what unit your file is in, run the command _Length on a line.

it will report back the length as well as the unit.
the dimension is just showing ‘10’…
_Length will report ‘10 millimeters’… or ‘10 meters’ etc.


between the unit conversion, dxf exporting and importing… it’s too difficult to precisely pinpoint where, if anywhere, an error is occurring.

so use _Length first just to see what rhino is thinking as your unit… use it to figure out which step exactly is it changing.


#5

if you’d like to change that to something else —

when you launch Rhino (or if it’s already open, go File-> New Using Template) ,you’ll see this on your splash screen:


if i want to make ‘Large Objects - Centimeters’ my default template, i click on it then an option to make it the default appears:


upon clicking that button, centimeters will now be my default template when opening a new file:


#6

Thanks Jeff that is really helpful I didn’t know you could do that. I’ll do that right away.
I’m still not sure every things right and I’ve no idea why the program suddenly changed a few parameters but I think I can get on with work thanks to that fix.
Thanks again for your help. Have a great day.

Simon :^)