Changes to Grasshopper Vertex-Colored Mesh rendering

It seems that in a recent Rhino 6 update, there was a change to the way vertex-colored meshes show up in the rhino viewport. Where in previous versions there was no shading applied to these meshes, now these meshes are shaded. Normally, I think this is an improvement - but I used to rely on the “unlit” nature of mesh coloring in order to draw on screen with consistent coloring (for example to do 2d diagramming with consistent, flat colors unaffected by the camera angle). Is it possible to add a toggle for this shading - or better yet, to introduce a custom preview component/option to draw in an “unshaded” way?

I noticed the same a while back but the current Rhino6 version I have seems to be back to unshaded again. I’m using a non-public build though (6.10.18244.2161, 09/01/2018), which one are you on?

On my Rhino version Version 6 SR9 (6.9.18240.23591, 08/28/2018)
On the right Grasshopper Sphere, on the left the same copied in Rhino




1 Like

guess i should have installed the latest update before running my mouth! :man_facepalming: