Unable to render mesh color using grasshopper in Rhino 7

I am new to grasshopper and I tried to create a mesh color for my mesh in grasshopper using Rhino 7.

I bake the product and here is how it looks in rendered view.

However, when I tried to render it, the color doesn’t show up.

Interestingly when I try to open my file in Rhino 6, the mesh color could be rendered.

May I know if anyone has any idea what could have happened?

Thank you!

this is the color mapping I used

Run TestShowPrivateContent if you haven’t before, then add a Cycles VertexColor material and assign to the baked mesh.

Thank you for the reply! but sorry may I ask are these two commands or how exactly do I run this in Rhino?

Sorry, I should’ve said TestShowPrivateContent. Just type that in Rhino and press enter. In the command-line history you should see the message Private content will be displayed. If the message says Private content will not be displayed run the command again until it does.

After that you can create a new material: press on the big plus in the materials panel, this gives you a pop-up. Choose Cycles VertexColor from that list.

It is working now! Thank you so much for the reply

1 Like