Catia/Solidworks Display Style in V6

I am wondering if anyone has had any success in creating a visual display mode similar to the clips below in a native Rhino viewport?

This visual style although simple is very compelling for our clients, and I find I end up needing to render every frame in Flamingo to achieve any type of similar aesthetic in Rhino.

I have tried the new Arctic render style, but the Ambient Occlusion seems to be too coarse to create visually appealing render mode. See below how the viewport looks with the default white - lots of very visible artefacts:

And if I override the white and show objects color it helps, but still poor:

Can you post that model or another with a screenshot of what you see in Rendered or Arctic modes? I’m not seeing the graininess of the skylight shadows here that you’ve shown… this is default Rendered mode here in the latest internal build of the day.


Hi Brian,

I’ve got a model which should be a good test candidate for preview speeds with the new Arctic display mode. This model displays at 60fps in wireframe and probably 20-25fps in shaded, but then slows down to 0.5fps or worse in Arctic.

Will DM you a Dropbox link.

Thanks for the sending the file in a PM. I responded there…

In short, I see what you show in your last screenshot but don’t have the slowdown I think you mentioned. It might be due to updates in the way shadows are handled dynamically that have yet to release in a WIP but I’m leaning towards GPU or driver as the cause of the difference. We’ll continue in the PM…

@BrianJ I’ve been noticing in recent WIP releases that the shadows in Arctic display mode have gotten more grainy.

Any idea why this might be happening? I have GPU tesselation enabled, and Antialiasing set to 8x.

The graininess seems to go away the closer I zoom in to a particular object.

Also I am noticing that even with Antialiasing cranked up, edges are showing aliased.

@lucasepp The shadows are tricky to get smooth when they are produced by thin, long objects as those in your scene. That’s why they look grainy. The algorithm can “miss” the object because it is so thin, and in those cases the pixel is not shadowed. It is possible to make the algorithm never miss objects, but it will then be much slower in all cases.

We are aware of the aliasing on edges which are adjacent to shadows. Are you using a 4k display?

@DavidEranen Yes, using a 4k display, xps 15 9560. Seems the results are similar independent of object aspect ratio?


@lucasepp It looks like your gamma is set to 1.0 - is that correct? The shadows look darker than they should. How does it look when set to 2.2?

Also, we halve the resolution of the skylight shadow on 4k displays because it would be too heavy to compute otherwise - that’s an additional reason why you see more aliasing and graininess. Looking at the screenshots in the browser they look fine, but when looking at them at full size they look less than fine. They should look quite good on your 4k monitor still, I would think.

Yes I had it set to 1.0 - just for a rendered effect I was going for. I like screen capturing out of Arctic for illustrations.

The funny thing is I’m almost certain that this behavior only appeared in the last few months of WIPs. I didn’t use to have this issue (my laptop has been the same).

E.g. have a look at this image (full size it): I obviously can’t use as a screen capture any more, too grainy.
Is there any way of enforcing a “Quality Arctic” display mode which kicks into gear a more intensive SSAO calculation?
Or maybe when ViewCapturetoFile/Clipboard is run, it automatically calculates more precisely prior to screen grab?

With Gamma = 1.0:

@lucasepp I’ve fixed this just now. When doing ViewCaptureToFile/ViewCaptureToClipboard/Print it will now capture at native resolution with boosted quality.

You should see the difference in the next WIP released on Tuesday.


1 Like

@DavidEranen Fantastic. This is what I love about Rhino and the team behind it - you guys are always so responsive and on top of things!

Really appreciate it.