Arctic rendering and viewport mode in WIP

unhandled

(Andrew le Bihan) #1

Some of the more alert among you might have noticed the new “Arctic” viewport mode. I’ve held off from announcing it because we’ve been waiting some other other technology to catch up, but as of today’s new WIP, I’d like to draw your collective attentions to these new features:

  1. Arctic display mode.

This is a viewport display that turns all of your objects white, turns the background white, and adds soft shadows. It is sometimes called “Clay” or “Plaster” on other platforms. It is essentially “ambient occlusion” mode.

  1. RenderArctic

This does much the same thing but in the final rendering output - it still renders with the current renderer, but before rendering it switches all of the materials to white (and so on). Naturally no permanent changes to the model are made.

  1. Improved skylight shadows and lighting in the Rendered display mode.

You should find there is much more definition, better handling of details and less blurring.

Please let us know what you think of all of these new features - we’d love to see images with the feature working - whether it works well or badly!

Cheers

  • Andy

(Bob McNeel) #2

This is what I get in the viewport… Everything is set to the defaults. Is this what is expected?

I don’t find it useful if I can’t see all the geometry.


(Bob McNeel) #3

This is what I get from RenderArctic. I was expecting that they would be nearly the same.


(Andrew le Bihan) #4

The reason the RhinoRender doesn’t work all that well with RenderArctic at the moment is that the skylight distribution is wrong. This is something that needs fixing - it certainly shouldn’t be that dark.

There are ways to make the upper image less white - but my concern is that there are people out there who really want it to be whiter than white.


(Andrew le Bihan) #5

And yes - that’s what’s expected for the Rhino logo. The image I showed was the same model in Rendered mode with the standard V6 defaults.


(John Brock) #6

I have similar problems:


(Andrew le Bihan) #7

JB

Press “Set to defaults” on the rendering panel to set up that V1 model to V6 rendering defaults.

Andy


(Rob McPherson) #8

Here’s my screen shot. Can’t say I like it though.

Regards,

Rob.


(John Brock) #9

That looks more like yours now. A bit noisy around the edges but much better.


(John Brock) #10

The actual Render is still gray:


#11

Yeah, looking pretty burned-out here too… and the anti-aliasing is nonexistent. --Mitch


(Willem Derks) #12

Hi Andy,

I’m happy with this mode! I agree with it being burned out. The defualt color being pure white is IMO not the optimal choice.:

Vanilla artic:

Changed material color to 230,230,230:

I think pure white should be reserved for backgrounds and the material needs to be light grey.

Thanks
-Willem


(Brian Gillespie) #13

Good idea. I’ve logged this as RH-36317.


#14

Could be nice if the arctic display mode could show edges and curves also. So, a washed out look could avoided and bring back details. Maybe it’s best looking if the edges are light visible only.


(Wim Dekeyser) #15

You can do that by changing the Surface edge settings - e.g. setting the Edge thickness to 1 instead of 0.
My wish around this would be to have a setting for silhouettes as well. Most of my stuff is cylindrical and the edges against the background disappear:


#16

+1 Silhouette is a “must” and should be an option for all display modes. (use the render mesh of course, not the actual nurbs calculated silhouette, unless you can do that in the background and update when mouse is idle)

And then only affect the silhouette color for selected objects.


#17

+2 Shilouette. For me is more important. I Like Artic.
Vittorio


#18

+1 Without silhouette the sketch look is useless.


(Wim Dekeyser) #19

With regards to the Arctic display mode, I have changed the default Viewport settings > Ground plane settings > Altitude and checked the Automatic altitude checkbox. This doesn’t seem to make a difference - the ground plane remains at z=0 and hides what’s below:

Also, is it possible to remove the line at the horizon (while faint, it is visible in that picture where the cursor is at)?


#20

It looks OK here, maybe a little too white but I’m also getting thick lines around the edges in some instances:

Copy to clipboard:

Screen shot:

Link to video here: http://screencast-o-matic.com/watch/cDXbQNQVrw

Andy