Better rendering defaults in Rhino WIP

One of the new rendering features in Rhino WIP is the new “look” of the standard renderings. The idea is to provide a single studio environment that provides useful reflections, soft shadows, ground shadows and a light background.

I would very much appreciate some testing and feedback in this area. These are a couple examples of what you could do:

  1. Load up some of your favorite models, switch to the Rendering panel and press the “Reset to Defaults” button. Then use Rendered or Raytraced display modes to view your model, and/or render them in RhinoRender. Comment on what you see.
  2. Try modelling something from scratch in rendered mode with a new model. Play around with materials - do they look as you expect?

Please post your results and comments in this thread. If you find bugs, please create YouTrack items for them.


Hi Andy, @nathanletwory

My viewport is all black, I deleted the raytraced mode and restarted for a fresh mode yet still black vp:
Rendering does work.

Command: RhinoCycles_ShowInfo
RhinoCycles 6.0.16278.10551 @ C:\Program Files\Rhino WIP\Plug-ins\RhinoCycles.rhp
CCSycles 6.0.16278.10551 @ C:\Program Files\Rhino WIP\Plug-ins\csycles.dll

Command: RhinoCycles_ListDevices
We have 2 devices
	Device 0: CPU > Intel Core i7-4700MQ CPU @ 2.40GHz > 0 | False | True | False | CPU
	Device 1: OPENCL_0 > Pitcairn > 0 | True | True | True | OpenCL
Command: _CommandHistory


Is the display also black in ‘Rendered’ display mode?

I merged a fix for this 1,5hrs ago. See


edit: to be precise bozo merged the fix for me. But I made the fix and created the pull request. :°

1 Like

Hi Andy, @BrianJ - the viewport (rendered display mode, all white) still looks a little blown out to me until I turn the Studio hdr intensity down a bit - like .7 or so. Full render looks pretty good at 1, so maybe that’s all that matters for right now, but I guess the viewport display could match it better, is what I’m noticing.


Full render

So far Cycles is very-too-much blown out at the default settings all in white and far better with the hdr at .7, but that might be a different topic again.


These tests look like some of my early-stage renderings when there are no materials assigned. It’s not entirely accurate to say the exposure is "blown out’ when all of the materials have no diffuse or reflective properties at all.

Can you automatically assign a default ‘over-ride material’ to all geometry (that has no material manually assigned yet) to solve this problem? In V-Ray, I typically use a 25 to 50% gray material and it works great until you get around to assigning materials.

The default material is a white diffuse material (white plaster).

Personally I’d always avoid materials where colors have one channel fully maxed, so instead of full white I’d go for a tiny bit greyed. Further more I’d tone down the strength of HDR, as @pascal suggests.

The new Studio exr I made was for OpenGL only. RR and Raytraced’s contrast is not correct with IBL as I understand it but OpenGL is. In tweaking it I tried to make white look white and not gray but the geometry does play a part. With that said, I agree that the stapler model you have there at .7 in OpenGL has a more even contrast but I think that intensity may make other models too gray. Personally I tend to place a default Paint material on models for some reflection as well so I’d try that with your model too as a test. @kyle was the main feedback on whites looking too gray but I also think that’s related to the SSAO shadow distance and attenuation of the skylight shadows so it’s hard to tell where the gray comes from exactly. reducing the brightness of the exr while also adjusting the distance and attenuation of the skylight shadows might yield the best balance.


FYI: I teach my students to avoid any material that is anywhere near 0,0,0 or 255,255,255. It rarely looks very realistic. The theory being anything that is ‘pure white’ cannot show brighter highlights, so it just disappears.

If you gave your plaster a 20% gray +/-, it might take care of it. A light gray will lighten up as soon as a light hits it, so you’ll never see that actual value. It just won’t disappear.

NOTE: This is a great idea! If you can have the app generate a high quality rendering with a single command, it will be fantastic. It is currently way too many obscure steps to accomplish. And, the same goes for the plug-ins that I use, like V-Ray.

I think both OpenGL and the renderer should have auto exposure!

Having to adjust the default studio just because we add a light or add sun just doesn’t make sense.

All modern games have HDR cameras with auto exposure, and I use it in Unity when I export my Rhino models there, so it is both fast and easy to implement. Then just add a +/- setting to the HDR camera and we are ready to render in no time.

I allways use a reference image to set the light to make sure white is WHITE and nothing less or more. That way I have full control over the colors and know that I can trust the output. If I want white to appear gray then that is something I want to control.

So setting default material to 20% gray makes much more sense than underexposing the studio by default.

Here is a typical setup for testing and as you can see the OpenGL default setting now is good.

Here is the link to the image in high res:

Yes! It was not until this thread that I realized pure white is a bad choice for setting up materials that need to be white. Changing the default material to off-white seems a solution that can eliminate quite some beginner frustration. I never realised a full white color basically destroys any option to get good highlights.


Hi Jorgen -
It’s just that the brightness of the studio with the hdr light source at 1.0 can be tuned - the V5 version of RhinoStudio.hdr does not light things up nearly as much at 1, it shows the dreaded gray whites even in in V6. V6’s RhinoStudio.exr is much better, nearly there with default white materials, but maybe can be tuned a bit more.


Yeah, here is the default rendered display mode.

But as you can see the default ground material appears similar, but they are not, cycles has miscalculated that default material for a long time.

Hi Jorgen - does this image include hitting ‘Reset to defaults’ in the rendering panel ?


Hi Pascal, The image was from the rendered display mode.
I just hit the button and captured a new view:

And then I did a “Rhino Render” and this is the result:

Both previous images were from a new file in the latest wip.

Render display mode is foreced to use the CPU as hint hint the 1070 isn’t supported yet.

Here is the file if you want it:
simple render setup.3dm (1.3 MB)

Just download the image in the link above.

Hi Jorgen- thanks - rendered display mode (not raytraced) looks like this, here - a little brighter than yours, maybe:

Rendering and ray traced looks pretty much like yours.


Yah, yah, yah! Today I started working on merging upstream code into our codebase :°

1 Like

Excellent stuff @nathanletwory
@pascal, it looks like the default ground material was lighter on my home system, at the office I get the same whiteness as you. (Time for a clean install I guess)

Regarding better rendering defaults… the one thing I think really hurts Rhino’s default rendering is it’s lacking material settings regarding reflections. We REALLY needs a reflection glossiness setting. Having to turn on bump for this just isn’t efficient.

All materials have varying degrees of reflection amount and glossiness. V-ray has put up a great chart to illustrate it:

From this page here:

This is crucial to quickly illustrate different plastic materials, or to add the illusion of clear coated wood.

Iimagine sliding a slider right there in the initial setting vs adding a noise shader to the bumpmap channel, and then have to tweak the settings regarding color, amount and size to get an ok diffuce reflection. Lot’s of users don’t even know that it is possible.

Transparency has a bug. If it is anything more than 0 then reflections are turned off. Reflections are a top of the layer setting and should not be affected by the opacity of the underlying settings. Also in OpenGL the materials colors disappear.

As you can see this affects both the rendering AND the material preview.

Raytraced display mode (Cycles) handles this MUCH better, and gives a MUCH better noise result with just 200 samples in just half the time it took to Rhino render the view. (I used the CPU to render the Raytraced view)
So honestly I see no reason for keeping Rhino Render much longer. But Raytraced display mode appears to only have one reflection bounce, even though the cycles setting for minimum_bounces=3, is that right? (Compare the reflections in the rims)