Can't select imported blocks


I’m having a strange issue with selecting blocks that are present in an imported rhino file. The issue only happens when using VisualArq template.

I imported an existing project file with several block instances into a new file with Visual Arq meters template. All the blocks are embedded in the original file and can be selected by clicking on them. In the new file with VA template I can’t select the blocks by directly clicking on them but I can select them if I use the Block Manager or by right-clicking the layer they are in and Select All.
This issue is specific to the VA template and does not happen if I use a normal rhino template file.

Best regards,

Hi @Filipe_Brandao, does that happen with a specific display mode, or with any? can you try to insert the files as “embed and linked” blocks and see if this fixes the problem? this is the recommended way to insert blocks in order that VIsualARQ displays correctly the objects in plan and seciton views with the right section attributes.
In any case, can you send the involved files to We will take a look.

Indeed! I hadn’t tried to use other display modes. If I choose any display mode other than “hidden” I’m able to select the blocks and all other lines. I think this settles the issue. Would you still like me to send the file?


Hi Felipe,
We met this issue in the past, and we fixed it. However, this case might be a different situation.
What VisualARQ and Rhino versions are you using?
If you zoom in or zoom out (still in Hidden display mode), can you select these blocks?

Yes, it would be a big help you if you can send us the files.

Yes, no problem in viewing the blocks.
Rhino: (6.22.20028.13281, 01/28/2020)

I’ll send you the files.


Hi @Filipe_Brandao ,

This issue has been fixed in the new 2.7 version.

Kind regards

1 Like