Wrong selection of VA Objects in different display modes

There is something wrong with selecting VA Objects in (I think all) display modes other than Hidden when the Cut Plane is toggled ON. This relates to both 3D and 2D view.

I’m using VA and Rhino 7.16.22053

VA Selection problem.3dm (2.9 MB)

Hi @Czaja,

I can reproduce the issue here on my computer. Actually, this is not a bug with VisualARQ objects, as the same happens if you explode those objects into native Rhino polysurfaces. The problem is in the level cut plane. If I change it to a normal Rhino Clipping Plane, selection works fine, even with VisualARQ objects.

My first assumption is that Rhino is picking the clipped part of the wall, which will be the correct selection if no cut plane were enabled.

I don’t know why “Hidden” display mode works fine.

Thanks for reporting it. We’ll let you know when we fix this issue.