Can't Open V6 file in latest V7 WIP (7.0.19316)

I just downloaded the latest V7 WIP ( 7.0.19316) and when I try to open any of my V6 files the loading screen hangs until I force quit. I tried restarting my computer and opening 3 different files before posting.

Hi, I logged a bug to get this investigated and solved.

Hi @caseymjones-

Thanks for reporting this. Unfortunately, I’m unable to reproduce what you are seeing on my end with a V6 file in RhinoWIP 7.0.19316.09306.

Can you please attach the Bighorn.3dm you are attempting to open? Additionally, it might be helpful to get the SystemInfo from the RhinoWIP and take a look as well.


Hi Dan,

Thanks for your quick reply. Please see system info below. Can I send you the Bighorn.3dm file in a private message or email?

Rhino 7 SR0 2019-11-12 (Public Build, 7.0.19316.09306, Git hash:master @ f84cdfdbadc6b0422b77c5b1f9d5df794f719a4f)
License type: Commercial, build 2019-11-12
License details: Cloud Zoo. In use by: CASEY ()
Expires on: 2019-12-27

Apple Intel 64-bit macOS Version 10.15.1 (Build 19B88) (Physical RAM: 32Gb)
Mac Model Identifier: MacBookPro15,3
Machine name: Casey’s MacBook Pro (2)
Language: en-US (MacOS default)

AMD Radeon Pro Vega 20 OpenGL Engine (OpenGL ver:4.1 ATI-3.2.24)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: ATI Technologies Inc.
Render version: 4.1
Shading Language: 4.10
Maximum Texture size: 16384 x 16384
Z-Buffer depth: n/a
Maximum Viewport size: 16384 x 16384
Total Video Memory: 4 GB
Graphics: Radeon Pro Vega 20
Displays: Color LCD (258dpi 2x)

Graphics processors
Intel UHD Graphics 630 (1536 MB)
Radeon Pro Vega 20 (4 GB)
Color LCD (1680 x 1050)

USB devices
Apple Inc.: Touch Bar Backlight
Apple Inc.: Touch Bar Display
Apple Inc.: Apple Internal Keyboard / Trackpad
Apple: Headset
Apple Inc.: Ambient Light Sensor
Apple Inc.: FaceTime HD Camera (Built-in)
Apple Inc.: Apple T2 Controller

Bluetooth devices

Third party kernel extensions
com.3dconnexion.driver (1.1.2) E8FB08D1-03FA-323C-820F-A5641C3FCCF9

Third party plugins

Rhino plugins
/Applications/ “RhinoCycles” 7.0.19316.9306
/Applications/ “Snapshots” 7.0.19316.1002
/Applications/ “Grasshopper” 7.0.19316.9306
/Applications/ “PanelingTools” 7.0.19316.1002
/Applications/ “Commands” 7.0.19316.9306
/Applications/ “Renderer Development Kit” 7.0.19316.1002
/Applications/ “RDK_EtoUI” 7.0.19316.9306
/Applications/ “Displacement” 7.0.19316.1002
/Applications/ “Rhino Render” 7.0.19316.9306
/Applications/ “IronPython” 7.0.19316.9306
/Applications/ “Legacy Rhino Render” 7.0.19316.1002

Thanks @caseymjones-

I can see the bug with your provided file. We’ll take a look. Thank you for reporting this!

This bug should be fixed in the latest RhinoWIP for 7.0. Please give it a try and thanks again for reporting this.