Can't open my files in rhino 7 (even the ones created with rhino 7)

hi everyone! I’ve installed Rhino 7 for Mac (evaluation) and now I cannot open my previous files, I can only create new ones. although I was able to do so a couple weeks ago, now whenever I want to open a file (version rhino 6 or 7, none opens), even one that I have created yesterday, rhino won’t load and open it, and no sign pops up. does anyone know how to solve this problem? I even deleted rhino and reinstalled it, and I introduced a new license key but it continues to happen. currently I have MacBook with the latest software (macos Big Sur 11.2.2). thanks in advance!!!

Hi -
We’ve seen a few reports of this behavior but have not been able to reproduce this on any of our systems.

Does that mean that it used to work with a previous version of Rhino 7? If so, which version were you running when this was still working?

Could you try exporting your current plist and then resetting it to the factory defaults to see if that resolves the issue?

  • wim

@c.m Just to add a little detail. We’d like to get a copy of your /Users/~/Library/Preferences/com.mcneel.rhinoceros.7.plist and take a look. Can you please take the following steps:

  1. Quit Rhino completely if it’s already open.
  2. In Finder, navigate to the Go menu, and select Go to folder…
  3. Enter the following path: ~/Library/Preferences. This should open that folder in Finder.
  4. Scroll down and find the file com.mcneel.rhinoceros.7.plist. You might have other similar files there; what we really want to take a look at has a 7 in it.
  5. On your keyboard, hold down the option key and drag com.mcneel.rhinoceros.7.plist to your Desktop. This is the file we’d like you to attach to a reply here.
  6. Launch the /Applications/Utilities/ (you can launch this from Finder or by searching Terminal in Spotlight).
  7. In Terminal, at the command prompt, please type:
    defaults delete com.mcneel.rhinoceros.7.plist
    and press enter. This resets Rhino 7’s preferences to factory defaults (we already have a backup copy on the Desktop).
  8. Launch Rhino and attempt to open a file. Does the problem persist? If this fixes the problem, please attach the com.mcneel.rhinoceros.7.plist to a reply here.

hi! I’ve done all steps upto step 6, but when launching terminal there is no command prompt (I mean, nothing pops up. I don’t know if that is what you were talking about). I attach an image showing what I see once I open the terminal.

. thanks!

Hi @c.m

hi! I’ve done all steps upto step 6, but when launching terminal there is no command prompt (I mean, nothing pops up. I don’t know if that is what you were talking about). I attach an image showing what I see once I open the terminal.

Well, that’s certainly odd :confused: …you ought to at least see something like a $ there in Terminal. That’s where you would enter the command to reset Rhino’s preferences…

Celine, in the meantime, can you please attach the com.mcneel.rhinoceros.7.plist you copied to your Desktop in step 5 above to a reply here? We don’t yet know whether or not this solves the problem…we are struggling to reproduce it.


com.mcneel.rhinoceros.7.plist (195.8 KB)

hi! I had sent an email regarding this problem to the tech support, and they have sent me a newer rhino 7 version for Mac that has worked. thank you very much for your help anyways!

1 Like

This is great news. :partying_face: It appears that @theoutside sent you a very recent build. I would be curious to see if others who are experiencing this problem can solve it by updating to the latest Service Release Candidate. I would appreciate hearing back from anyone who does this and finds it solves the problem (or not).

Hi i’ve similar problem may i get a newer rhino7 cor mac?
thank you

Hi Enrico -

You have answered to a topic that is a year old. The version that you are running now should be a lot more recent than the update that was provided to that other user.
Please run the Rhino SystemInfo command and copy-paste the result here.

hi, thank you for your answer, see below

Rhino 7 SR16 2022-3-8 (Rhino 7, 7.16.22067.13002, Git hash:master @ aa7902c94c5aa33511e60d30f82b636be43bc85f)
License type: Non definito, build 2022-03-08
License details: Stand-Alone

Apple macOS Versione 11.6 (Build 20G165) (Physical RAM: 8Gb)
Rhino is running in Rosetta2 on Apple Silicon
Mac Model Identifier: MacBookPro17,1
Language: it-IT (MacOS default)

Apple M1 (OpenGL ver:4.1 Metal - 71.7.1)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: Apple
Render version: 4.1
Shading Language: 4.10
Maximum Texture size: 16384 x 16384
Z-Buffer depth: n/a
Maximum Viewport size: 16384 x 16384
Total Video Memory: 5461 MB
Graphics: Apple M1
Displays: Unknown (227dpi 2x)

Graphics processors
Apple M1
Color LCD (1280 x 800 @ 60.00Hz)

USB devices

Bluetooth devices

Third party kernel extensions

Third party plugins

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino
/Applications/Rhino “PanelingTools” 7.16.22067.1002
/Applications/Rhino “Displacement” 7.16.22067.1002
/Applications/Rhino “Renderer Development Kit” 7.16.22067.1002
/Applications/Rhino “Snapshots” 7.16.22067.1002
/Applications/Rhino “Commands” 7.16.22067.13002
/Applications/Rhino “Rhino Render” 7.16.22067.13002
/Applications/Rhino “RDK_EtoUI” 7.16.22067.13002
/Applications/Rhino “RhinoCycles” 7.16.22067.13002

Hi Enrico -
I see that your evaluation license expired earlier this month and that you are now using a cracked version of Rhino. I’m not sure what issue you are running into with that one but it’s rather unlikely that we can help you with that.

Hi Wim, i’ve downloaded the evaluation license from rhino website i’m aware i cannot save after 90days but i just want to see draw, it’s not cracked at all, i’ve seen this Celine post on the top and though it can be solved

Hi any comments? thank you in advance

Sorry to bother Wim, but is possible to have an answer? i’ve just downloaded the trial version and it worked for some week.