Drawing disappears when closing block editor

This just happened to me for the second time. Like others, I have lost hours of work. This is infuriating.

Never seen anything like this, until it happened to me today as well. Saving on a remote drive, so there’s no autosave… I saved the (destroyed) file under a new name, and one intriguing fact is that the file size is similar to what it was (~5mb) with all the lost objects intact; this makes me wonder whether they’re mysteriously “still there.”

@mcneel this seems like… a pretty significant bug…

I’m running Mojave on a <1-year-old MBP, Rhino 6 SR24 2020-3-19.

Same thing happened to me as well, I lost my files which I worked almost 5 hours on it, so frustrating.

SAME HAPPENED TO ME! DOES ANYBODY KNOW WHAT TO DO?

Working with Version 6 (6.25.20114.03572, 2020-04-23)

Hello - is there any consistency in this at all in what edits you make in the BlockEdit session for this to happen? Is the resulting file actually empty or are there hidden objects? Can you send an example file where this has happened?
And, does Undo restore anything?

@JohnM - just fyi, this thread…

-Pascal

This has happened to me, too. Exiting the block editor and finding all my work gone. I decided to close the document and discard changes, and it reverted to the previously saved version which seems to have been right before the disaster happened. So I didn’t loose much work, but I almost had a heart attack.

@pascal – This may help or not, but when this happened I was working in a rush, so I exited the block editor by clicking apply and then closing the block editor window, and IMMEDIATELY clicking or double-clicking on the model space in my haste to get that window out of the way. It usually takes a moment (a second or less) for the block editor to close and unlock all objects and for things to return to normal, but in my rush I think I clicked in the model space before the block editor got a chance to unlock everything etc. Maybe if you beat that process by clicking on the model space, the process somehow gets messed up?

For the record, I’ve previously had the similar problem of exiting block editor and finding all objects in my drawing locked (as discussed here Can't get out of block editing) and i also have the distinct memory of clicking or double clicking on the model space IMMEDIATELY after closing the block editor window, while the unlocking process was underway but perhaps not completed.

Hope this helps.
Bruno.

Hi Bruno - thanks, I’ll try to reproduce this - I don’t know how you can check this without putting your data at more risk, but it would be good to know whether or not the objects are still in the file but hidden, or is the file really empty when this happens. If you have the nerve to SaveAs a copy in this state, should it happen again, I’d love to have the resulting file.

-Pascal

that might be a bug, but I had a similar experience quite inexplicable, which was my fault in the end. The block all at once dissapeared leaving my active document empty. The thing is that searching for each block I was able to see that very strangely all my geometry, because of some strange sequence of command in the block editor went all in the block in which I was working, dissapearing when I closed the block editor. it is a very banal error, but I never made such an “error”… maybe your cases are similar. I hope it helps.

HI @pascal my drawing also just disappeared… I don’t know if its because of blocks like the other people… but I was using lots of materials inside blocks (and blocks of blocks). I’m on 6.26 for Mac. In two years of using Rhino this is a first for me.

Sorry I’m replying to myself. I solved my own question! My ENTIRE drawing somehow accidentally ended up in one of my “Blocks” that I made…

Thats so odd! I had about 4 blocks and someone a bunch of layers all copied themselves onto one of my blocks… I don’t suppose anyone else had this problem? Or perhaps it was just me…

This just happened to me too… and just like you said the entire drawing can be found inside of one random block in my project too! Very strange and odd indeed.

I hope this get fixed soon. This wasn’t my first time with this bug, but at least now I know what to look for when this happens next time.

Once again entire drawing inside one random block… nice.

Can you please send a file and the instructions needed to repeat this problem?
If we can repeat it, we can git it on the pile to be fixed.

Thanks

This just happened to me (Rhino 6.30 on Mac). I really don’t know what triggered it.
I open BlockEdit, did my modification and when I clicked Apply everything vanished.

As some user here pointed out, I looked into every single block that was in the file (A LOT & TIME CONSUMING) and finally found it in the block that I was editing (of course that block was near the end of the list, but next time it happens I’m sure going to check that edited one first…

I really hope this gets fixed… It’s annoying if it keeps happening and not good for the stress either.

Thanks.

Thanks for the report. I’m trying to reproduce this but so far can’t using the same build. Do you have a 3dm file with a block in it and the steps to reproduce this? One thought that may be a variable is where the 3dm is saved on your Mac. Is it in a cloud synced folder for instance or on an external drive? I’m wondering if macOS versioning might be involved but this is just a guess at the moment. We’ll need to reproduce it here to get it in front of the developers.

I was using files in a cloud folder and by stopping the sync I was able to retrieve an older version of the destroyed file (at the moment I also had rhino autosave on). It was a linework file and the objects are definitely not hidden, as the file size reduced from 33MB to 4MB. Personally, I have also noticed other irregularities when I am constantly working on a file that contains blocks, i.e. assigned linetypes changed, all 2d objects swapped layers or the layer colours shuffled, which is very very weird. Anyways, here is my file after data loss. AFTER.3dm (4.5 MB)

This just happened to my twice with Rhino 7 (7.2.21012.17002, 2021-01-12) on Mac. My File size reduced from 84MB to 4MB. Could restore an older file with “Revert to”, nevertheless hours of work vanished. I don’t know how to live with this Problem. Not using blocks and groups anymore?

Have been encountering this issue on (6.34.21034.07002, 2021-02-03) multiple times similar to the previous posters about editing blocks… I use time machine backup with the file open and roll it back one step (assuming you are trying to recover your latest work immediately after the issue arises). The other issue is as what some of the previous posters mentioned, eg. objects moving to different layers, block text being either duplicated (outside of the block) or not updated. This more frequently happens when I edit the type in the Properties: Text sidebar but not when I double click the text for the pop up to appear.

Hi All!

I am so glad I found this thread because I am having the same issue. I just deleted my previous message about it on accident, lol.

Anyway, it happens to me in both V6 and V7 for Mac, both are updated to the latest builds and my computer is running MacOS Catalina 10.15.7 (19H524)

It seems to happen if I click one too many times right after exiting the block editor - all of a sudden everything disappears. It’s not hidden or deleted, and I cannot undo the action to get it back, like others who have posted, I have to revert to a previous version to fix it.

Please let me know what I can do to help with this - I copied the model that appears to be “blank” and could share that with the McNeel team to take a look… The file is still 17MB even though it looks like there is nothing inside.

I can send more info on my computer etc as well if that’s helpful. Let me know.

I want to make another report of this. One of my students actually had it happen right in front of me when changing content in a title block in layout mode. After ‘Apply’ the complete content of the file was gone. Could it have to do with Mac operating system doing an automated save on exactly the wrong moment, so it saves in block edit stage where no other geometry is visible?
Then I had another emergency case this morning to solve: Another student had a almost completely empty file as well. The only rescue was to browse to a multiple hours earlier version of the work. This is a huge bug that needs to be solved asap. Also this is what her layers looked like when it happened:

as you can see all the layer colors and print width info is gone.