Can't delete GH canvas components on Rhino.Inside Revit

I am not able to delete any GH canvas component while using it inside Revit (Rhino.Inside - WIP). Whenever I do it, GH goes on the background and Revit pops-up.

This applies to any component at all. I have tried FN+Delete and any suggestions I have found online, without success.

Help anyone?


no solution here, but I got a related bug.
The delete key (not Backspace) is not working in Rhino.
Typing the “delete” command does work.


Since I updated last week and right now again I have the same issue in Revit 2019. I cannot delete, Copy/Paste, Alt-Drag-Copy in Rhino.inside and GH!

Is there any solution?

I just realized, when I start a command like duplicate edge in Rhino , keys work in GH…


This works in Revit 2017, 2018, and 2020, but is a problem in 2019.0.
I recently update my Revit 2019.0 to 2019.2.2 and seems is now fixed.

Here you can see the Updates history of Revit 2019, and here what is new in 2019.2.2

I am using Revit 2020.2 and I have same issue. Can not delete GH components.
I am trying to delete List.Item but unable to do so. I can from Edit.
Any help will be appreciated.


Hopefuly next Tuesday release will fix this.

1 Like

Hi @michaldengusiak,
Did you find a workaround?

I have the latest version of Rhino.Inside and Revit 2020. The issue remains.

Hi, it is not fixed yet … Hopefully will be soon :slight_smile:


The fix is available.
You will need to update Rhino WIP and Rhino.Inside Revit.

Hi @kike,

I have the same problem on Revit 2019.0
I have Rhino WIP 7.0.20014.11185
and Rhino Inside from 21.01.2020.

Does this mean that with the newest release of Rhino WIP, this issue will go away on Revit 2019.0 as well?

Or is it necessarily to update to 2019.2 in addition to having the newest Rhino WIP?

With the last release should work on any version and on any window, this includes Rhino, Grasshopper and PythonEditor.

In your case you need to update Rhino and Rhino.Inside Revit.

I just tested and thanks to all amazing Rhino team :slight_smile: @kike
it is working for me now :slight_smile: huurey, tested and apporved :slight_smile: :clap:

1 Like

Using Revit 2020.2. Downloaded and installed RIR today (3/2/20) and using Rhino 7 Commercial. Based on this thread it seems to be solved, but I’m still having issues.