Grasshopper for Mac - Delete


(Tom Norris23) #1

Is there a way to change the settings so the Delete key deletes components not the backspace key?
Thanks
Tom


(Dan Belcher) #2

Hi Tom-

delete deletes components for me. I just tested it on the latest RhinoWIP (5E334w).

What is your hardware setup? Laptop? Desktop?


(Tom Norris23) #3

Hi dan,

I’m using the same WIP.

It’s an iMac, I will post full specs tomorrow when I’m back in the office!

Tom


#4

fwiw, delete key deletes components for me as well.
(ie- works as expected)


(Tom Norris23) #5

Hi Dan,

iMac (Retina 5K, 27-inch, Late 2015) 3.3 GHz Intel Core i5 16 GB 1867 MHz DDR3

If it helps in Rhino itself the “delete” does delete, so it is only in GH where only back space is deleting.

Could it be related to British Keyboards?
Thanks
Tom


(Dan Belcher) #6

That’s what I’m wondering here. Thanks for the information that it does work in Rhino, but not Grasshopper…that’s an interesting clue.

Can you please provide some more additional information? Please navigate to Rhinoceros > About Rhinoceros > More info… > Copy to clipboard and paste the content back into a reply here.


(Tom Norris23) #7

Software information

Software versions
Rhinoceros version: 5.4 WIP (5E334w)
Rhinoceros path: /Applications/RhinoWIP.app
IronPython version: not installed
WIP expiration: 19 January 2018
Language: en-GB (MacOS default)
macOS version: Version 10.12.6 (Build 16G1036)

Plug-ins
None

Third party kernel extensions
None

Hardware information

Computer hardware
Hardware model: iMac17,1
Processor: Intel Core i5-6600 CPU @ 3.30GHz
Memory: 16 GB
Architecture: Intel 64 bit

Video hardware
Graphics: AMD Radeon R9 M395 2048 MB
Memory: 2048 MB
Screen size: 2560 x 1440
Displays: iMac (217dpi 2x)

USB devices
Broadcom Corp.: Bluetooth USB Host Controller
Apple Inc.: FaceTime HD Camera (Built-in)
Apple Inc.: Apple Keyboard
Logitech: USB Optical Mouse

Bluetooth devices
None

OpenGL information

OpenGL software
OpenGL version: 2.1 ATI-1.51.8
Render version: 2.1
Shading language: 1.20
Maximum texture size: 16384 x 16384
Z-buffer depth: 24 bits
Maximum viewport size: 16384 x 16384

Implementation settings
Use texture compression: No

Appearance settings
Antialiasing: 4x
Mip map filtering: None
Anisotropic filtering: None


(Dan Belcher) #8

Thanks. Just out of curiosity, does hitting fn+delete work to delete components on your keyboard?


(Tom Norris23) #9

Apologies for the delay,

I have tried fn + delete and it still does not delete!?


(Dan Belcher) #10

@will are you running macOS in en-GB with an Apple Keyboard purchased in the UK? Do you see this behavior in Grasshopper?


(Will Pearson) #11

@dan I have the Magic Keyboard (without num pad), so no delete key.


(Dan Belcher) #12

Ah! The Magic Keyboard differs from British English…

to US English…

@tom.norris23 I’m still not sure this is the keyboard. That said, what does your keyboard look like?


(Tom Norris23) #13

Hi Dan,

The keyboard I was using was like the top image you posted but it included a num pad, and delete keys above sperated arrows, the home and end key were arrows and the return key was L shaped
I think is is the one circled in this photo:


(Dan Belcher) #14

Well, I’m stumped. I wish I could reproduce this on my end. I presume when you swap out keyboards, this problem persists (?)


(Tom Norris23) #15

Unfortunately I am no longer in a position where I can test this setup, sorry I cant be more help.
Thanks
Tom