CAD Import - No leaders (Multi Leaders)

So I guess CAD imports neglect to include Multi Leaders? I swear I never had this problem before.

rhino leader test.dwg (67.3 KB)

Hello- Rhino does not have an equivalent object that I know of - I suppose it is just converting to text since it can’t decide on which leader to use.


I’m going to try and see if dimension leaders convert (since Rhino leaders are embedded in an annotation style I think?). The leaders in my DWG are multi-leaders.

I’m also going to see if they import into layouts.

This kind of sucks because it wrecks my intended workflow.

Everything in the program seems so close to perfect but you reach a hiccup right at the very end. It otherwise works so well with cad.

Hi Keith,
Thanks. We can see that.
We have logged:
RH-71782 AutoCAD Multileader without Text Do not Import to Rhino

Mary Ann Fugier
McNeel Technical Support

1 Like


For the record I think it’s only worth fixing if it’s an easy fix. I’m already contemplating a couple different directions to circumnavigate the issue, which I anticipate will take me half of a Saturday.

Hi Keith,
Issues in your file Leader test 2.DWG were logged as 2 issues from :
RH-71782 - AutoCAD MultiLeaders with No Text Do not Import to Rhino
RH-71783 - Leader with User Arrow Needs Arrow Block Assigned

Some of the issues in your file Leader test 3 DWG were related to :
RH-71782 - AutoCAD MultiLeaders without Text Do not Import to Rhino.
There are leaders in AutoCAD with the leader deleted and a frame around the text.
As a workaround, you can Explode the Leader into text and the curve around it.
Then it will import to Rhino properly.

Other leaders were having an issue with the AutoCAD Annotation scale setting, And I need to adjust a couple styles to prompt for mtext because of RH-71782.

These leaders were set to use the AutoCAD Annotation scale. Rhino does not currently support this. So as a workaround, you need to turn this off.

You can turn it off in the Leader style.

Or just change the properties to turn off this setting after being create.

The leader import and look like they did in AutoCAD with this setting off:

I found I had already been logged as a bug 6 years ago. :frowning:
But sadly no love here for this bug.
RH-36210 Rhino Not Opening DWG/DXFs with Annotation Scale On Correctly

So I rewrote the but as RH-71799 Annotation-Scale-not-Imported-to-Rhino and included some a clearer example files. Also since Rhino does not support Annotations scale exactly like AutoCAD, at import these will be reset to Model scale, which is a setting that both AutoCAD and Rhino support. They will also import back to AutoCAD as Model scale.

In the mean time, you will need to embrace the workaround suggested or fix the scales once they are in Rhino. Of course, I know that you need the RH-71782 (AutoCAD MultiLeaders with No Text Do not Import to Rhino) to be fixed. You will be notified here when there is a fix in the WIP for you to test.

Hope this helps.
Mary Ann Fugier

leader 3 no anno scale.dwg (46.5 KB)

Hi Keith,
I would like to understand this better:

What are the specific features for documenting in AutoCAD that Rhino does not have or you prefer to use in AutoCAD?
If Rhino does not have them, I want to verify that we have the feature request logged in the tracking system.

Mary Ann Fugier

It’s definitely helpful Mary!

I’m quite handy at creating scripts in AutoCAD. So many of the above work-arounds will be easy(ish) to implement. The key for me is knowing what I have to work with, and adjusting my standards accordingly from there. The little surprises are what halted my overall progress (temporarily).

What are the specific features for documenting in AutoCAD that Rhino does not have or you prefer to use in AutoCAD?

Perhaps I could make a video at some point. It would be way easier to convey that way. But I’ll leave a brief explaination.

Dimensions (which are quite good in Rhino once you get used to them):

In AutoCAD, immediately after selecting the object you have access to all relevant grips. In Rhino, you need a couple clicks. In the example shown I would either have to zoom in, or select one of the grips off to the side to expose the text’s grip. Note that his is very minor, the leader issue described below is far more important.
image image

AutoCAD’s automatic dimension leaders suck. What I actually often do is just use leaders; I make sure the text is set to be able to just move manually.
Note that although the dimension is snapping to the “endpoint”, it will snap to the dimension line’s “midpoint”. The red is my leader which I’ve added over top of the dimensions automatic leader.

I already have my ACAD style leader macro’s programmed in Rhino, so I can just add my leaders automatically (and quickly). I can’t snap to the dimension lines however, so adding leaders right at the mid point is harder.
Maybe it’s worth taking a consensus as to whether other users would prefer more ‘snapping’ on dimension objects; personally, I feel that if the dimension’s node’s are snaps, the mid-point of that line should also be a snap.

Not a big issue, but moving leaders while the leader pointer stays stationary is a tad slower in Rhino, and may be un-intuitive for some if you have landings turned off. You have to shift-select all nodes in the boundary shown when the leader is selected:

In AutoCAD, you can use the “stretch” command before the object is even selected. I might be missing something here. And also I understand that objects in Rhino are more “dynamic” than ACAD’s and much of the functionality of performing commands on ACAD’s objects is built into a Rhino object’s functionality. I’m getting more and more used to Rhino’s leaders and as mentioned have already built my macro.

This is probably most important: AutoCAD’s text editor is way more modern and feature rich.

GstarCAD’s editor (below) is hot on Autodesk’s heels (along with BricsCAD’s and most other CAD’s):

Hi @keithscadservices,
This is helpful.

I made this terribly quick video on editing dimension with control pts.

With the Mouse setting to turn on Control pt on Annotations, and modifying the Display mode to show the control points better, it seems pretty efficient here.

Again I made a quick video with how to dimension to the mid pt of a leader.
Stretch in Rhino is really best described as the moving some control points on an object, and leaving others behind.
When you pick on a curve or annotation, the points turn on and you can select the ones you want to move. You will see that in the video too.

I don’t know what a lot of these icons mean, but here is a start on the list:

Rhino already has:

  • Bold/Italic/Underline
  • Change case options in the TextEdit modal dialog (you get this when you double click, not the one you get in Properties.)
  • Horizonal stacked fractions that use special character [[/x/y]]
  • Spell check is in Rhino 8. You can turn it on with the TestToggleSpellCheckOnAnnotationText

I logged a YT for these enhancement to Text: RH-71945 Enhancements to Text:

  • Superscript
  • Subscript
  • Tabs: hanging indent
  • Bullet list with bullet style options
  • Number list
  • Diagonal fractions
  • Overscore
  • Undo/Redo in Text command

I know there is a lot there. But if we can focus on the biggest pain points, then we can carve into the other items in a the next round.

Let me know if you agree with my list of priority enhancements to Text.
Mary Ann Fugier

Hi Mary. Great video! I learnt a few things.

I’ve found another issue that’s a bit harder to work around: Leaders seem to be importing onto the “default” layer regardless of what layer I have them on in ACAD.

This would be harder to fix because I don’t have the Rhino scripting skills that I have in ACAD. I’ve already found a few tricks to sort out much of the other stuff.

1 Like

Hi Keith,
Good to hear the videos were helpful.

I tried it with one of mine own DWG, (attached) and the exact layer I am using in AutoCAD, is the layer that Rhino imports.

Please send a small test file that will show me the issue.

Mary Ann Fugier

anno text dim leaderS 02.dwg (39.2 KB)

No file needed as even your file has the same behavior. I checked so many things :-S (various things in the leader style, fresh drawing, layer already existing, etc…). The layer it’s on will import.


I suppose I could run a script after importing: “If” my leader is a certain style put it on the layer I want.

For now I have to give the AutoCAD → Rhino thing a rest. I may have mentioned I’m working on what is just a basic template and trying to do so in a way that imports nicely into Rhino.

I still plan to make a video: Just the differences between ACAD and Rhino and why I gravitate towards ACAD’s annotations.

Hi Keith,
To continue investigating this issue, I need 1 leader in a DWG and I need the DXF of the same leader that you generate from your AutoCAD.

These files will hopefully tell me where you need to look for the culprit.
Mary Fugier

I’ve also tried GstarCAD 2020 with the same result. Maybe I’m missing a setting within Rhino itself? Strange that only the leaders are affected.

# RhinoTest 014.dwg (111.0 KB)
# RhinoTest 014.dxf (680.6 KB)

Edit: Note that I’ve placed two leaders in the bottom right (with text so they actually show up) - those are the only things we’re currently looking at. I think for now I’m going to wait until Rhino 8 until I try to create a template that imports correctly. For now I’m just getting my AutoCAD template’s ducks in a row.

Hi Keith,
Thank you for the files.
I was able to duplicate the issue and I logged RH-72048.
I will let you know when I see a fix.

All bugs fixes are applied to the current development version which is Rhino 8 WIP.
So you will be able to test the fix there when it is available.

Mary Ann Fugier

The hardest part sometimes is ‘duplicating’ the issue. Thanks again for your help on this!!

Was there any progress on this? For years Rhino 7 (and previous versions, I can’t say exactly when) has been importing AutoCAD leaders onto the current layer. This is always unwelcome at best.

I would actually be able to create an AutoLISP script that would export all the leaders… let’s say in CSV format (or whatever) and include layer information. Then I could open Rhino and run a C# script to import that data. This would be easy enough in 2D. For 3D and multiple planes I have next to no experience.

The thing is that if I can do it…

Hi @anon ,
This was fixed in Rhino 8 on 3 Jan 2023.
It should have been announced here. But I do not see it.

Rhino 7 users are welcome to download and test the fix in the Rhino 8 Beta here.

Let us know if it works for you.
Mary Ann Fugier

1 Like

It’s nice to hear but I think many of us really wish these things were fixed in R7. If something is broken, and doesn’t take a monumental effort to fix… it should be fixed. I see how much resources they are dumping into Rhino in Revit among other things. Importing a CAD file isn’t anything groundbreaking. But I suppose if the issue only affects a small portion of customers…

Many people won’t be able to upgrade to R8 (due to hardware issues). I might stay at R7 for up to a year just to avoid having to upgrade. I’ve kind of made other arrangements to work around the lack of being able to import DWG’s effectively. It’s kind of a shame because most of the stuff imports really well. It almost wastes all that effort by not polishing off the final details.