Bug: Transparency not working in Ghosted

The transparency setting in Ghosted view does not seem to be functioning in Rhino 8 sr5. Here is a screenshot of a file in Rhino 6 in Ghosted view, with transparency set to 35%. Note the horizontal line is visible on the right.

Here is the exact same file in Rhino 8. Again, in Ghosted view with 35% transparency.

In fact, I see no difference at all in transparency whether it is set to 10% or 90%.

Here is my systeminfo just in case:
Rhino 8 SR5 2024-3-12 (Rhino 8, 8.5.24072.13001, Git hash:master @ e3530849b75f00b2b977766a567ae29b055837e9)
License type: Educational Lab License, build 2024-03-12
License details: Cloud Zoo

Windows 10 (10.0.19045 SR0.0) or greater (Physical RAM: 32GB)
.NET 7.0.17

Computer platform: LAPTOP - Unplugged [92% battery remaining] ~258 minutes left

Hybrid graphics configuration.
Primary display: Intel(R) UHD Graphics (Intel) Memory: 1GB, Driver date: 6-1-2021 (M-D-Y).
> Integrated graphics device with 3 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port
Primary OpenGL: NVIDIA Quadro RTX 4000 with Max-Q Design (NVidia) Memory: 8GB, Driver date: 2-15-2024 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 551.61
> Integrated accelerated graphics device with 4 adapter port(s)
- Video pass-through to primary display device

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 2-15-2024
Driver Version: 31.0.15.5161
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 8 GB

Rhino plugins that do not ship with Rhino
C:\Users\mmagee\AppData\Roaming\McNeel\Rhinoceros\packages\8.0\NVIDIADenoiser\0.4.3\NVIDIADenoiser.Windows.rhp “NVIDIADenoiser.Windows” 0.4.3.0

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 8\Plug-ins\Commands.rhp “Commands” 8.5.24072.13001
C:\Program Files\Rhino 8\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 8\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Rhino 8\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 8.5.24072.13001
C:\Program Files\Rhino 8\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
C:\Program Files\Rhino 8\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 8.5.24072.13001
C:\Program Files\Rhino 8\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 8\Plug-ins\MeshCommands.rhp “MeshCommands” 8.5.24072.13001
C:\Program Files\Rhino 8\Plug-ins\RhinoCycles.rhp “RhinoCycles” 8.5.24072.13001
C:\Program Files\Rhino 8\Plug-ins\RhinoCode\RhinoCodePlugin.rhp “RhinoCodePlugin” 8.5.24072.13001
C:\Program Files\Rhino 8\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 8.5.24072.13001
C:\Program Files\Rhino 8\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 8\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino 8\Plug-ins\Calc.rhp “Calc”
C:\Program Files\Rhino 8\Plug-ins\SectionTools.rhp “SectionTools”

Just to show it in more detail, here is another set of screenshots. All 4 viewports are in Ghosted view, so you should be able to see the letter “M” through the center of the ring in top view and the side of the ring in Right view. In Front view, you should also be able to see the floor of the inset on the top of the ring.

In the first screenshot the transparency is set to 10%. In the second, the transparency is set to 90%. Note that there is no change whatsoever in any of the viewports

Ghosted Transparency = 10%

Ghosted Transparency = 90%

Hi Mike- I’ll check into this, thanks.

If ghosted transparency is zero, it reverts to the layer transparency - I will try to find out whether this is by design or not - it may well be - I am not sure what I’d expect - added transparency, Ghosted plus layer?

@MikeM - I think this qualifies as Not A Bug the moment but I am curious to know what the expected behavior is, for you. Would you expect the transparancies to be added up, or maybe never be less than the layer transparency, or?

@MikeM - maybe I am confused - are you saying Ghosted by itself, with no layer transparency invloved, simply fails and is opaque? Sorry, I somehow jumped to an assumption that you were involving layer transparency - you never said anything about that.

-Pascal

1 Like

Hi Pascal,

Your second guess is correct. I’m not using any layer transparency at all, only Ghosted to make everything semi-transparent. I would expect the exact same behavior as happens in Rhino 6 and 7. (See above rhino 6 screenshot).

Hi Mike - something is busted -Does the bad thing happen in a brand new file with just a box added?

can you please try resetting Ghosted to defaults (Export it first , and post the ini file, please) and see if that makes anything better?

-Pascal

Hi Pascal,

Ok it looks like the problem is with the .ini file. Here is a screenshot with the default interface followed by a screenshot of the same thing with the custom .ini file.

Can you help me figure out what’s wrong in the .ini file?



GIA Rhino Interface.ini (186.4 KB)
Ghosted Boxes.3dm (37.2 KB)

I think I figured it out, @pascal. It’s the shadow settings. If I turn off the Shadows in the custom .ini version of Ghosted, then the objects appear transparent again.

Thanks for the help!

1 Like

Got it thanks!
RH-81453 Shadows stop Ghosted transparency

-Pascal