BUG Shader Black Issue in Rendered Mode on Rhino 8 And 7

Bug Report: RH-78738

Hello Unity Community,

I’m encountering an issue in Rhino 7 where my shaders turn black in the rendered mode. This happens intermittently, and I haven’t been able to pinpoint the exact cause. Raytraced works well.

Has anyone else experienced this issue? Any suggestions on how to resolve it would be greatly appreciated.

Thank you!

Hardware: RTX 3090, 96Gb ram, I 5 9600k
Rhino Version 8 SR1

Bug report AM50

Hi @AlanMattano,

Can you please try a couple things:

  • Subscribe to the Release Candidate update stream on Windows or on Mac and install the latest 8.2 RC. Does that fix it?

If not, can you please:

  1. In Rhino 8, type SystemInfo and press Enter
  2. Copy and Paste your system info here. It may be that you need an updated video driver.
1 Like

I´m using two 4K 55 TV monitors. The main one at 120Hz HDR

Rhino 8 SR1 2023-11-21 (Rhino 8, 8.1.23325.13001, Git hash:master @ 8a4a437248efac5d9cb04d3904481b83e4c23a64)
License type: Commercial, build 2023-11-21
License details: Cloud Zoo

Windows 11 (10.0.22621 SR0.0) or greater (Physical RAM: 96Gb)
.NET 7.0.0

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: NVIDIA GeForce RTX 3090 (NVidia) Memory: 24GB, Driver date: 10-4-2023 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 537.58
> Accelerated graphics device with 4 adapter port(s)
- Windows Main Display attached to adapter port #0

Secondary graphics devices.
NVIDIA GeForce RTX 3060 (NVidia) Memory: 12GB, Driver date: 10-4-2023 (M-D-Y).
> Accelerated graphics device with 4 adapter port(s)
- Secondary monitor attached to adapter port #0

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 8x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 10-4-2023
Driver Version:
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 24 GB

Rhino plugins that do not ship with Rhino
C:\ProgramData\McNeel\Rhinoceros\7.0\Plug-ins\Datasmith Rhino Exporter (d1fdc795-b334-4933-b680-088119cdc6bb)\DatasmithRhino7.rhp “Datasmith Exporter”
C:\Users\Animism\AppData\Roaming\McNeel\Rhinoceros\packages\8.0\NVIDIADenoiser\0.4.3\NVIDIADenoiser.Windows.rhp “NVIDIADenoiser.Windows”
C:\Users\Animism\AppData\Roaming\McNeel\Rhinoceros\8.0\Plug-ins\Bella (813de3fb-18eb-405f-bfcd-b0b4d3da91fb)\\bella_rhino.rhp “Bella”
C:\Users\Animism\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\SubstanceImporter\2.0.3\Substance.Win.rhp “SubstanceImporter”

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 8\Plug-ins\SolidTools.rhp “SolidTools”
C:\Program Files\Rhino 8\Plug-ins\Commands.rhp “Commands” 8.1.23325.13001
C:\Program Files\Rhino 8\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 8\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 8.1.23325.13001
C:\Program Files\Rhino 8\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
C:\Program Files\Rhino 8\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 8.1.23325.13001
C:\Program Files\Rhino 8\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 8\Plug-ins\MeshCommands.rhp “MeshCommands” 8.1.23325.13001
C:\Program Files\Rhino 8\Plug-ins\RhinoCycles.rhp “RhinoCycles” 8.1.23325.13001
C:\Program Files\Rhino 8\Plug-ins\RhinoCode\RhinoCodePlugin.rhp “RhinoCodePlugin” 8.1.23325.13001
C:\Program Files\Rhino 8\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 8.1.23325.13001
C:\Program Files\Rhino 8\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 8\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino 8\Plug-ins\SectionTools.rhp “SectionTools”

Lets go to your Document Properties and uncheck all your 3rd party plugins and restart Rhino.

I will try.

Bug Report: RH-78738

Here is an example file with an isolated object.
BadRenderedBlack.3dm (3.7 MB)

any idea?

Looks good here. Did you test with no 3rd party plugins & get the latest Release Candidate? The youtrack has been passed to material dev. Does a new material behave the same?

Also Custom Shader type is having the same problem as PBR.

Yes, there are new materials, with and without textures. PBR and Custom are affected.


This one, in particular is a very basic material:

Can it be related to:?

I’ve observed the following:

  1. Switching to the base Default Material is not black.
  2. If I select the appropriate material (which is not corrupt), by using Match, it can alter the material to black.
  3. Undoing this change reverts the material from black back to its normal nominal state
  4. Same problem for Rhino 7 as well. Rh7 File example included.

BadRenderedBlackRh7.3dm (3.1 MB)

Can you try deleting the shader cache and see if that resolves this issue? (_TestShaderCache)

I run it but it’s still black.


When I adjust the slider in the Materials Panel, the icon representing the material preview temporarily turns black during the slider movement. Once I stop moving the slider, the preview returns to the correct display.

Is the issue of the shader’s default base appearing with no color and brightness (flat black) related to the previously mentioned problem?

After running it, you need to run TestShaderCache again to enable it again. After that restart Rhino. Any luck?

Edit: if the above doesn’t help, I’d try a clean install of the display drivers next.

I have done all that this morning, including enabling and disabling the feature, followed by a restart. I also installed the latest stable version of the Studio Drivers.

Could you clarify whether the cache should be enabled or disabled for normal use?

Ps: Additionally, even if I correct the shader issue, it eventually reverts back to black after some time.

It should be on

Can you confirm that you did a clean install?

Yes, I can confirm that even after a clean install, the issue persists. I wouldn’t recommend others to do this, as a clean install requires significant time to reconfigure my desktop, windows bar, and other settings.

This problem seems specific to Rhino and doesn’t occur with other software I use, which suggests it’s a Rhino-related issue. I’m still working on isolating it. It’s surprising, as it appears I’m the only one experiencing this.

Did you already update your Rhino to latest SR, as mentioned in the first YT you made and by @Japhy? I assumed you already did, but want to rule that out.

The issue I’ve been experiencing has existed since Rhino 7. I’m now focusing on getting it resolved, as there were previously other high-priority bugs requiring attention. For my work, I typically avoid using alpha or beta versions of software, unless they contain a specific bug fix for which there is no other workaround, and the link was broken temporarily. I’m pleased to report that

the problem has been fixed in Version 8 SR2 (8.2.23339.13001, 2023-12-05).

This fix seems to address the issue that I suspect might be the same as RH-74512, where material previews were not updating correctly. Good Job Team!!

1 Like