Bug Export with Origin, file type?


#1

For some reason if you try and use Export with Origin on a preselected object you can only use 3dm as the export file type, works ok if you start the command then select.

Mark


(Pascal Golay) #2

Hi Mark- I only get 3dm in either case here. It does seem like it ought to just work for any Rhino-supported format and it is on the bug list multiple times. I have no idea why this is hard, but apparently it is. I’ll see if I can give it a nudge.

-Pascal


#3

Yes please fix this. I would like to create a cplane on a rotate surface, then export that object as an STL for example with the previously tilted surface laying flat (for 3D printing for example).


(Mikolaj Jarski) #4

This bug still persists with sr7 (unless you don’t pick an insertion point). Are there chances to get rid of it?


(Pascal Golay) #5

Hi Bjron - RemapCplane, Export and Undo will help for now… I’ll ask the developer again but I do not think this is easy to fix.

Like so, with objects pre selected and custom plane active in the current view:

! _RemapCPlane _Cplane _Top _Export _Pause _Pause _Undo

-Pascal


#6

Hi, looks like an interesting workaround. Right now, I can’t get pass this though:

Name of CPlane to map to: Top
Specify a different CPlane.

Regards

  • Björn

#7

Usually that means Top is already active in the “from” view…

–Mitch


#8

I was in perspective viewport when I ran it if that’s what you mean?


#9

Possibly - did you set a custom CPlane with the origin you want in the Perspective viewport before running the macro? Otherwise the default CPlane in Perspective is Top.

–Mitch


#10

Yes I did, that box is tilted from the world top cplane, and then I used Cplane Surface to set a custom Cplane to the top surface of the tilted box.


#11

OK, in theory if the object is selected and the Perspective viewport is active, then it should work… Seems to here if I try to reproduce what you are doing. Don’t know why it doesn’t on your end…

–Mitch


(Pascal Golay) #12

Hi Bjorn -my guess is there is currently no view that has the Top CPlane… ?

-Pascal


#13

Ah, perhaps you’re right. I use “Universal cplanes” in the options. Which makes the other views adapt to the newly created cplane. That means no view uses the original world top plane anymore, is that what you mean?


(Pascal Golay) #14

Hi Bjorn- that is what I mean- I found it fails if there is no Top cplane active anywhere. This seems dumb to me- I would expect the default world planes could always be called up any time in Rhino, whether they are in a view currently or not… I’ll check with the developer.

-Pascal


#15

As CPlanes are localized like views, if the name doesn’t actually exist in the file, it will fail. In any case the macro fails here with Rhino in French. I guess the alternative is to use a script where you can define the translation without having to use RemapCPlane which seems to only want localized existing names or a views with an active CPlane…

–Mitch


#16

Hi,
To come back to the exportWithOrigin bug :
I can’t choose any other format than .3dm, except if insertion point is the world origin (point 0).
Does this mean that other file formats don’t support insertion point information ?
I need advice on this


#17

I have the same problem. If you can solve… it would be ideal!


(Pascal Golay) #18

Hi Baptiste - this is fixed in the next version of Rhino. For now in V5 you’ll have to move things so that the desired origin is offset to the world origin, Export, then Undo.

-Pascal


#19

Understood,
Thank you for this fix


(Pascal Golay) #20

Here’s a macro:

! Select Pause Move Pause Pause w0,0,0 Export Pause Undo

-Pascal