(SOLVED) Exporting and Importing between rhino files


#1

so i have been using rhino a extensively for a few months now and one thing i haven’t found the answer two so far not from lack of searching either.

so i design pieces and assemblies in rhino. and sometimes pieces can interchange between different assemblies. but the assemblies dont always have the same world coordinate system.

so what i am trying to do is as a simple example in the source file i have a part oriented to a hole and so i would think if i set the cplane to be in the center of the hole. on my other assembly i have the same hole but is on a different world cplane so i set my cplane to the same hole. now back to the source drawing i export with origin my part and then go to my new assembly and import it. and its no where close to the hole.

im familiar with autocad. and autocad does this flawlessly i set my ucs to the hole in the source. wblock the part out go in to the second assembly set the ucs to the hole and insert and works just the way i desire.

rhino IMHO out does autocad in everything except this point and i think its not rhino i just dont know how to do it.


#2

Landon, export with origin and pick a point at 0,0,0 in your source file. When you import that into your destination, it will come in exactly relative to the new 0,0,0 in the destination file.


#3

Figured it out. Thank you for the reply! i was doing exactly what you were saying cause that seemed like it would work. the problem was i needed an update to the program and i guess that must have been broken at one point after it updated it was fixed and worked as expected.


#4

I lied i just fixed one part. when i was on the older version. when i selected the point to be the origin it ignored it and would use the world origin. i did a example just to be sure i drew a box. then moved the box positive x y and z just to get it off the world origin. then i set the cplane to a corrner of the box. and did export with origin and used the cplane 0,0,0. opend a new drawing and if it worked right it should import right on the world 0,0,0 and it didnt it ploped it exactly where i moved it. in the source drawing. but the update fixed that issue. that works properly now.

now what i dont know is it is importing to the world 0,0,0 instead of the cplane 0,0,0. i have tried import and insert


#5

Ok i finally got the part where i want it i found out my second problem.

it seems import just plops whatever file your importing into the document World cplane.

the issue with insert was in the insertion point field i deselected prompt and told it 0,0,0 and i guess that uses the world cplane as well.

so what fixed it is i tried selecting prompt and it had the part oriented to the current cplane and all i had to do was type in 0,0,0 and it went right where i wanted it.

glad i finally got this worked out. i was having to export to autocad and position it then export it from autocad back in to rhino to finish editing.


#6

glad you got it working and welcome to the ex-acad user group! :smile: I haven’t had to use acad for a job in a few years now. I love staying in my warm Rhino home.