Broken macro / Visual Arq related?

Okay, I made this macro about 2 months ago. Working fine… until I installed Visual Arq. At least I think that’s what did it. Anyways I may be wrong about that. Is anyone else able to figure out what could be going on here?

-SetObjectName NewPlan
-Layout Detail 17 11 0 < (stuck here)
-Detail A P T 3/8,10-5/8,0 7-1/8,5-1/2,0
-Detail A P F 3/8,5-1/2,0 13-7/8,3/8,0
-Detail A P R 7-1/8,10-5/8,0 10-7/8,5-1/2,0
-Detail E SelCircular 3/8,10-5/8,0 9
-SelName NewPlan
-Invert
-SetObjectName Hide
-HideInDetail
-SelNone
-HideInDetail _Detail -SelName Hide Enter
-Invert
-Zoom A S
-SetDisplayMode M S
-Detail N
-Detail E SelCircular 7-1/8,10-5/8,0 8
-SetDisplayMode M S
-Detail N
-Detail E SelCircular 7-1/8,3/8,0 9
-SetDisplayMode M S
-Detail N
-Detail A P P 10-7/8,10-5/8,0 13-7/8,7-5/8,0
-Detail E SelCircular 10-7/8,10-5/8,0 5
-SetDisplayMode M S
-SetObjectDisplayMode -SelName NewPlan Enter M H
-SetObjectName -SelName NewPlan Enter Done
-SetObjectName -SelName Hide Enter BackToNormal
-SelAll
-Zoom S
-Detail N

Could have some connection to this issue

System info below

Rhino 7 SR29 2023-4-17 (Rhino 7, 7.29.23107.03001, Git hash:master @ 5f05ef3a2eea3d910c4c2fb79ccc75b413d33ca7)
License type: Commercial, build 2023-04-17
License details: Cloud Zoo

Windows 10 (10.0.19045 SR0.0) or greater (Physical RAM: 32Gb)

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: NVIDIA GeForce RTX 2060 (NVidia) Memory: 6GB, Driver date: 7-21-2022 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 516.94
> Accelerated graphics device with 4 adapter port(s)
- Windows Main Display attached to adapter port #0

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: None
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 7-21-2022
Driver Version: 31.0.15.1694
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 6 GB

Rhino plugins that do not ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Tibidabo\VisualARQ.rhp “VisualARQ”
C:\Program Files\Rhino 7\Plug-ins\Tibidabo\Tibidabo.rhp “Tibidabo”
C:\Program Files\Scan&Solve Pro for Rhino 6 & 7\SnSPro_Rhino_6+7.rhp “Scan&Solve Pro for Rhino” 1.0.0.0

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.29.23107.3001
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RPC.rhp “RPC”
C:\Program Files\Rhino 7\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.29.23107.3001
C:\Program Files\Rhino 7\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.29.23107.3001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\IronPython\RhinoDLR_Python.rhp “IronPython” 7.29.23107.3001
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.29.23107.3001
C:\Program Files\Rhino 7\Plug-ins\Grasshopper\GrasshopperPlugin.rhp “Grasshopper” 7.29.23107.3001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.29.23107.3001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino 7\Plug-ins\Calc.rhp “Calc”

The crash report indicates it may be the Tibidabo tool in VisualArq that is crashing.

To verify this, I would recommend disabling Tibidabo and the other plug-ins that did not ship with Rhino, restart, and see if the crashing stops.
Assuming it does, then enable the disabled plug-ins, one at a time, restart, and test again until you find it.

I’ve moved this topic to the VisualArq category so their developers see it.

Any luck?

1 Like

Thanks @John_Brock !
Your amazing. That did the trick.
I disabled the Tibidabo plugin and now the macro is working as normal again!
Your the best Thanks!
-Ryan

Hi @Ryan14,

I was able to reproduce the problem. Tibidabo was interrupting the current command when switching between model and layout space. This bug seems to have been around since 2015, but no one has noticed or reported it before.

Here is a preview release of VisualARQ 2.13.2 that fixes this problem:
http://visualarq.s3.amazonaws.com/download/visualarq-2.13.2.17313-rhino7-setup-snapshot.msi

Please try it and let me know if it works.

Thanks,

Enric

1 Like

Good afternoon @enric
Thank you very much for that! That did the trick! Much appreciated!
:grinning:
-Ryan