Brazil getting stuck on "Opening Render Session" [SOLVED]


#1

Hi, I have a complex model which is getting stuck when rendering on the message in Brazil that says “Opening Render Session”. I have tried leaving it open (even overnight) but it does not progress.

The model is a piece of jewellery heavily set with stones with a “diamond” Brazil glass material applied.

The file is quite large but I have uploaded it in the hope that someone can point out a solution or a workaround:
https://drive.google.com/file/d/0ByHQahWoMSwKYjdFajdDbFNzbDQ/view?usp=sharing


(Brian James) #2

Hi Aaron,

The file renders here with only a second delay between opening render session and updating ray server. I’m wondering if you might have any other plugins involved in the file like maybe Bongo. If you do, try disabling that plugin in Options>Plugins and then restart Rhino to try the render again as a test.

One thing I noticed in the settings was that you have caustics enabled but this won’t do anything unless the light objects also have Photons enabled in the Properties panel>Light section when they are selected. In this case it doesn’t do much here to enable them for the point light above the model so you might try turning off caustics in the Brazil settings too as another test to see if that’s involved.

Any luck?


#3

Thanks @BrianJ can I confirm that it renders okay once the “Lid Diamond” layer is turned on at your end? I just realised that I turned this off when saving the file. It is this layer that seems to stop the rendering.

I have tried your suggestions with regards to stopping Bongo and removing the caustics settings - but these did not help.

I also require Bongo as the object needs to spin for an animation.


(Chris Kuether ) #4

Perhaps you could use ‘turntable’ for your animation…


#5

Thanks @ChrisK it is my understanding that “turntable” spins the viewport? As I have set up scene lights I was hoping to have the object spin in place. If it is this that is holding things up I would happily change it though!

I could not get the render to work with Bongo turned off however.


(Brian James) #6

Hi @Aaron_Jeewood I reproduced the long wait when the diamonds were displayed, thanks for that detail. I didn’t wait more than 5 mins before quitting Rhino so I don’t know how long it would take but I figured out the fix regardless. The issue appears to be two fold, the number of polygons of all of the combined diamonds and the NURBS objects passing their render meshes to Brazil which takes time. Luckily they are block instances so the fix is easy.

  • Double click one of the diamonds to open the block editor
  • Use ExtractRenderMesh on the diamond
  • Delete the polysurface diamond
  • Select the mesh diamond
  • Use ReduceMesh on it and check the Planar Only option
  • Accept the block edit changes

It should render then. Before these steps you could see that the render mesh for one diamond is 318 polygons and there are 3,773 diamonds so it was roughly 1.2 million polys just for the diamonds. More polys = more time when it comes to rendering. We cut it in half with this workflow while also cutting out the middle man of having the NURBS objects pass their render meshes to Brazil.

Did that work for you?


#7

Wow, perfect Brian! Thank you so much