Brazil slow big scenes

Hello every body,
I used to work on rhino + C4D for rendering, but export were really painfull.
I’d like to switch to Brazil to render directly in rhino but on my big architectural scenes I can’t work no more in render preview and it’s very slow to move in the scene.

anyone could help to give a solution for an easyway to work with brazil ?

Thank You

Hi Paul,

Do you have a sample file and can you describe more about the spot that is slow for you? You can upload large models to , put “for BrianJ” in the comments and I’ll take a look. In general, if you are experiencing a slow viewport rotation in Rendered mode, I would suggest adjusting your render mesh settings both globally and per selection if necessary. You might also try using the free Neon plugin as the preview for Brazil. Many of the Brazil material options and settings are supported through Neon and it is CPU vs. GPU based.