Bongo Looping stuck a tick 9


(David J Buckley) #1

Hi All,
I have an animation with key frames from 0 to 18 that I want to loop. The looping dialog box only allows the stoping point to be at key frame 0 to 9. If I enter a value larger than 9 it changes the number back to 9.
Any ideas?
Thanks!
David


(David J Buckley) #2

I also am realizing another issue I am having with this same file. Now no matter how I change the animation when I render it the animation reverts back to a previous set up. In other words it records the same animation now matter how I edit the key frames. I make my changes, scrub the slider and see the changes but when I render it an older version gets run? I am having trouble telling user error from program issues. Has anyone experienced this?
Many Thanks!
David


(Luc Adriaenssen) #3

Apparently the input boxes of the Looping dialog are bugged. On my system the stop position is maximum 99 and the start position is limited to stop minus 1(which is logical). Apparently on your system the max is 9??

The looping markers on the timeline however can be dragged wherever you like. The animation will behave correctly.

Luc


(Luc Adriaenssen) #4

We never heard of Bongo rendering an “old” version of a model. It’s hardly imaginable.

Are you sure you used the Render Animation command?
image
The Video Encoder (used to make a video out of a pile of images) will make the same video again en again without new images being generated first.

Luc


(David J Buckley) #5

Thanks Luc,

When I drag the looping markers the marker moves but the recorded animation in not looped past 9.

Best,

DJB

David & Kristen Buckley

SV Sayonara

(D) 843.735.9663
(K) 843.412.3188

www.watercraftdesign.com


(David J Buckley) #6

Thanks Luc!

I am using the render animation command exactly as you have shown. I also have repeatedly tried to change the folder and file name just in case. Any chance you can log on to my machine virtually to see this with your own eyes?

Many Thanks!

David

David & Kristen Buckley

SV Sayonara

(D) 843.735.9663
(K) 843.412.3188

www.watercraftdesign.com


(David J Buckley) #7

Luc,

I have been able to get the looping to work only by dragging the tick on the time line.

I sent a screen shot video of the recording problem to support@mcneel.com can you take a look at that?

I understand your comment about the encoder. The actual new images created in a new folder are not correct, the model is not being animated as I have directed it.

Thanks!

David


(Luc Adriaenssen) #8

David,

Your model and movie ended up at Marika’s desk. No prob, Marika is in charge of Bongo’s users support. When you want to send me stuff it’s better to mail it directly luc@mcneel.com.

I cannot reproduce the problem you have with the looping settings (apart from the limitation at 99 in the dialog, that I mentioned earlier).

Concerning the discrepancy between scrubbed and rendered animation: when you preview (‘play’) the animation you’ll notice that curves 39 (green) and 40 (red) do NOT execute their Morphing data, they just move back and forth. Also “Bongo: Cannot find morphing solution. Parameter mismatch.” is displayed repeatedly in the command history window. The same happens when you render the animation.

Curves 43 and 45 on the other hand preform perfectly. After stripping down the model to the essence, removing the Looping and the History, the behavior of objects 39 and 40 still remains corrupt - they only perform the morphing when the animation is ‘stepped’ trough. I assume something went wrong internally while you were struggling setting up the first elements of the animation. I’ll forward your model to the developers so they can take a look.

I cannot find a cure for the 2 corrupt curves. I’m afraid you’ll have to ‘remake’ them, and consequently
the History based flag.

Luc


(David J Buckley) #9

Thank You Luc!

I will rebuild everything from scratch tomorrow with fresh eyes and confidence. As I am sure you, know every thing goes together quicker on the fifth or sixth try!

Best,

David


(Luc Adriaenssen) #10

I’ve done some little experimenting.

When - in animation mode - you alter the weight of a control point of a curve (or a surface) the “Parameter mismatch” your model suffers from occurs. Perhaps that is what you did for curves 39 and 40.
So you should restrain to only move the control points while creating a Morphing curve, not edit the weight.

Luc