Blocks only displaying as Wireframe regardless of Viewport Display Mode

Hi All

I have an odd issue that one of my colleagues is experiencing. When she uses blocks they will only display as wireframe, regardless of what display mode she’s in.

I’m unable to replicate the issue, but when I open one of her files and place a block, it will only display as wireframe, even if I copy it into a new file.

If I explode the block on my computer and then re-block it, the problem goes away.

We’re both using NVIDIA Quadro K2100M graphics cards so I don’t think this is the issue.

Does anyone have any idea what’s going on?


1 Like

Can you please send a small Rhino file with one of the block instances that exhibits this problem?

Yes I just messaged it to you - thanks!

Hi Brian,

have tried to double click the block, then use _SetObjectDisplayMode _Mode=_UseView ?


Thanks Clement. Yes we tried that to no avail. Oddly enough, the blocks display correctly relative to the view when in block edit mode, but not when you’re viewing blocks place in the file.

The block was created a long way from the coordinate origin of 0,0, but the block’s base point was 0,0
Your instance is too far from the coordinate origin. That’s why the render mesh is shifted off to the left side.

I think if you redefine your block so the geometry AND the base point are both near 0,0, then you’ll be able to instance them way off in space like you did.

1 Like

Aha. Will have the user test this solution and get back to you w/confirmation.

Thanks again for the quick help.

Hey John this has been confirmed as the error. Funny, we actually ran into this same issue (excessive distance from origin) with a VRay render error just last week.