Blocked Objects and Clipping Planes

When clipped, a block will not display as a solid. Not sure if this is a setting I cant find or if this is a regression or…

@mary

Hi Brady are the objects inside the block set to solid in the section style?

(Rhino WIP, 8.0.22277.12305)

image

Setting the subobjects to Section Style by clipping plane is working for me, too.

Changing to by Parent then changing one block to Solid

image

By Layer

Hmm. I can get a “solid fill” but that’s not the same as displaying the clipped object as solid all the way through showing the material properties. I spent some time messing with all those settings you pointed out but couldnt get more than the solid fill hatch pattern. I attached a screenshot from rhino 7 which is what I need to achieve.


Hi Brady -
You’ll need to set the clipping plane fill to the render material in the display mode that you are using:

If that’s not it, please post a file that we can check.
-wim

That didnt do it. Is that a block reference you have show in that screenshot? The problem relates to only blocked objects.

Hi Brady -

Yes, that is a block instance:
image

-wim

Hmmm. I just opened a blank WIP file. Made a cube, blocked it, clipped it…this is what I am getting.


Block Object WIP options

My results (Rhino WIP, 8.0.22277.12305)

What’s your systemInfo?

Rhino 8 SR0 2022-10-4 (Rhino WIP, 8.0.22277.12305, Git hash:master @ c1431b875fa2bfebc0a16c88bb959d6070d51d85)
License type: Commercial, build 2022-10-04
License details: Cloud Zoo
Expires on: 2022-11-18

Windows 10 (10.0.19044 SR0.0) or greater (Physical RAM: 32Gb)

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: NVIDIA RTX A4000 (NVidia) Memory: 16GB, Driver date: 9-12-2022 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 517.40
> Accelerated graphics device with 4 adapter port(s)
- Windows Main Display attached to adapter port #0
- Secondary monitor attached to adapter port #1

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 8x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 9-12-2022
Driver Version: 31.0.15.1740
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 16376 MB

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 8 WIP\Plug-ins\Commands.rhp “Commands” 8.0.22277.12305
C:\Program Files\Rhino 8 WIP\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 8 WIP\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 8 WIP\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 8 WIP\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 8 WIP\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 8.0.22277.12305
C:\Program Files\Rhino 8 WIP\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 8.0.22277.12305
C:\Program Files\Rhino 8 WIP\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 8 WIP\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 8 WIP\Plug-ins\Constraints.rhp “Constraints”
C:\Program Files\Rhino 8 WIP\Plug-ins\RhinoCycles.rhp “RhinoCycles” 8.0.22277.12305
C:\Program Files\Rhino 8 WIP\Plug-ins\RhinoCode\RhinoRoslyn.rhp “RhinoRoslyn” 8.0.22277.12305
C:\Program Files\Rhino 8 WIP\Plug-ins\RhinoCode\RhinoCodePlugin.rhp “RhinoCodePlugin” 8.0.22277.12305
C:\Program Files\Rhino 8 WIP\Plug-ins\RhinoCode\RhinoCPython.rhp “RhinoCPython” 8.0.22277.12305
C:\Program Files\Rhino 8 WIP\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 8.0.22277.12305
C:\Program Files\Rhino 8 WIP\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 8 WIP\Plug-ins\BlockEdit.rhp “BlockEdit” 8.0.22277.12305
C:\Program Files\Rhino 8 WIP\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino 8 WIP\Plug-ins\ConstraintsUI.rhp “Constraints UI” 8.0.22277.12305
C:\Users\brady\AppData\Roaming\McNeel\Rhinoceros\packages\8.0\SectionTools\2022.9.16.918\SectionTools.rhp “SectionTools”

Hi Brady,
I am thinking it is an issue with your existing file.
Email me and let me know if I already have this file to test.
If it is a setting in the file or the display mode, I should be able to isolate it here.

Thanks for your help.
Sincerely,
Mary Ann Fugier

You already have the file, its that big file we have been working in lately

Awesome!
Thanks.
Stay tuned. :slight_smile:

Sincerely,
Mary Ann Fugier

Hi @brady1,
I was able to duplicate this with Rhino 8WIP.
I logged RH-70874 Render Material Not Displaying for Clipped Block.

Thank you for letting us know.
We will post here what it is fixed.

Sincerely,
Mary Ann Fugier

Thank you!

Hi Brady,
I also logged this one for RH-70877 Clipping Plane Material Not Showing As Clipping Plane Fill

Not sure of you have run into it.
But it is on the pile too.
However, it see on any object, not specific to a block.

Thanks!
Mary Ann Fugier

I have seen this one yes! Thanks Mary

1 Like