Best way to export to Autocad and retain pictureFrame image and surfaces?

unhandled

#1

Hi
V5
save as DWG R12 Natural, when I open it back into rhino I see no raster images for my pictureFrame and no shaded surfaces.

What settings or file type options should I be using to get across to someone the rasters and the surfaces ?

Steve


Exporting images from Rhino to .dwg
(John Brock) #2

Set up an export scheme that uses AutoCAD 2004, saves surfaces as solids, and click on the Save Textures option when you name the DWG file
PF.dwg (15.2 KB)


#3

Hi,
I select the items including the raster image placed with PictureFrame, choose file > export selected and select dwg, click options and choose 2004 Solids, I click on edit schemes as I see nothing about textures but still dont see textures options, I save as this.

File new, open dwg and no surfaces or textures.

Where are the settings for exporting the textures and getting surfaces ?

I open your PF.dwg into a new Rhino and go with options presented as I see nothing for textures etc. I see no object at all ?

I am able to open my dwg exports.

What settings should I select when opening your PF.dwg ?

Steve


(John Brock) #4

The R12 DWG file format doesn’t support Solids or the image.
You’ll need to choose a newer AutoCAD version like I did.


(Vanessa Steeg) #5

I believe what John is referring to is the Save Textures option in the Export dialog box. This option is not in the Edit Schemes dialog box, but once you come out of it and back into the Export (or Save As…) box. See attached.

Does that do it?


(John Brock) #6

It still can’t be the R12 file format. It has to be newer. I used the 2004 format.


#7

Hi John,… but I did select solid 2004.

VaneSteeg,
Hi, thanks for the texture location.

So I try again, select dwg, select 2004 solid, tick textures and save as dwg.

Open it into rhino, shaded on and I see surfaces :slight_smile:

I dont however see the raster image jpg.

What needs doing to make sure the plans also show up ?

Do I need to email them separately, nightmare as it means trying to locate them.

Could I save the file as a second copy and embed the plans, then do the export selected solid dwg tick textures etc.

Steve


(John Brock) #8

I don’t know what to tell you.

Here is a 3dm file with a surface made with PictureFrame, and a DWG exported using the 2004 Solids export scheme. The DWG opens in Rhino V5 and in AutoCAD 2012 with the image attached to the surface.

PF_Guido.3dm (162.1 KB) PF_Guido.dwg (15.4 KB)


(John Brock) #9

In the PictureFrame command, do you have the Command line option to embed the image in the file set to Yes?


#10

Hi,
The rasters are plans I am working over, and I have many of them, they are sometimes a few Mb each,

Embed bitmap set to no, else it would casue me big problems as the file gets slow with the loads of images turned on as it is.

If it requires this particular plan I wish to export with the drawing to be embeded (its not a raster on a surface I have made, but an engineering plan placed in with Pictureframe) then how do I make it embeded a few days after using pictureFrame to place it into my work ?

I opened your 3dm, I see a white square with txt ’ image not found’ on it .

I opened the dwg into rhino new file and see absolutely nothing !

Steve


(Pascal Golay) #11

This should make no difference to performance once the file is loaded.
To embed after the fact, you can use the

TestSuckTextureIntoBitmapTable

command.

-Pascal


(John Brock) #12

See if these updated versions work.
I embedded the iPF_Guido 2.dwg (15.4 KB) PF_Guido 2.3dm (181.9 KB) mage into the 3dm file as described.


#13

Hi, I can see the 3dm file, pic of a moustachiod hatted gent.

I see nothing at all for the dwg going file>open

Hi Pascal,

I copied out to a new rhino file the plan and assoc objects then ran TestSuckTextureIntoBitmapTable. It said to pick the object, I clicked the unlocked and ungrouped raster image, there was no feedback to say success… a momentary flicker maybe as I picked it. Tried it twice, first time it was grouped. made no difference. I lok in properties for the image but there is nothing I see to say if its embedded or not. Where would it say ?

I exported it as solid2004 with texture ticked. open the dwg, no raster image.

These are jpg’s by the way, does that make a difference ?

I am living dangerously as it is regards PC memory and Rhino and anything that might pose a memory hit I avoid, with 30 or more large raster images I dont need them embeded so will keep it that way. If required for dqwg export I shall copy out the relevant objects and jpg’s. Every time I am forced to reboot the PC 'cos its memory is clogged up, there is a good chance it wont boot again. I need to get this mammoth job done before rebuilding it, nightmare situation but its life for me at the mo…14hrs a day/7 days a week.

Steve


(John Brock) #14

Strange. I can open the Rhino created DWG file and once open, the surface is there with the image of Father Guido Sarducci of SNL fame.
If I open the DWG in AutoCAD 2012 I see it there too.
I double checked by renaming the JPG image file after I make the Rhino and AutoCAD files so I know it’s not finding the image on the local disk.


#15

John,

I to am having the same problem with imbedded bitmaps. When I export the .3dm file to a 8.dwg file (correctly selecting the scheme options and export texture check box) the bit maps are extracted from the .3dm and put in the file with the exported .dwg. If I delete the extracted bitmap files from the file and open the .dwg in rhino the bitmaps do not appear.

The same is true for the dwg of father Guito does not include the bit map as well. I suspect that when you open the guito dwg that it is finding the separate image files and loading them.

What can I do to get the image files into the dwg files that I am exporting?

Ken


(Shahzu19) #16

sorry its again blank in dwg format.
let me describe you,
you are able to see the image in both file cause you have the picture in that directory.
kindly remove picture from that directory after export the file.
now open the dwg file you will get nothing.


(Shahzu19) #17

you are true…
but kindly delete that picture from the directory and open rhino created dwg again.