Export a solid as dxf sees no solid when I import it

Hi, V5 and also V4,
select my solid, go export selected as dxf, choose options r12 natural, then open the dxf file and there is no solid, wireframe mode or shaded, nothing there !

all layers are turned on.

Does same in both V4 and V5, yet I have exported solids from certainly V4 as DXF R12 natural in the past, I browse to them and open them and I see the solid.

This is the first time trying for an export since installing Rhino V5 and also V4 onto my new win7 64bit pro PC.

Do we need to install some kind of dxf export plugin so as to export as dxf, something I havent added to my new PC ?


You need to use a DWG/DXF named export scheme that exports Solids.
There was no default named scheme in V4 but the option was there as of SR7 I think.
box.dxf (171.5 KB)

How or where do I get this DWG/DXF export scheme ? Is it a download or some code I install or what ?

You say there was no default named scheme in V4 but was there as of SR7.

I am with V4 SR9 and had V4 SR9 on my previous PC which was able to create dxf files with solids. I dont recall having to select anything special to do so.

I have the same V4 SR9 on my new PC as well as Rhino V5, which I presume has this scheme by default, NEITHER will create a dxf with solid.

Did I overlook some setting when exporting.

Please explain the steps in V5 to export a solid as dxf.



So you’ve never explored the export options?

1 - SaveAs or Export, give it a DWG/DXF name.
2 - Edit named export schemes

3 - Make a new one:

4 - Give it a descriptive name:

5 - Set Surfaces to export as Solids:

You should be able to figure out the rest.

Hi John,
for the times I have exported as dxf and successfully created one, I just selected dxf r12 and that was that, dont recall this at all ! strange as it may seem. I’ll give it a go.


ok,reporting back…fails.

I followed your steps exactly, below is the scheme I set up.

I went with my existing choice of Release 12 so edit scheme started off with settings as such, I clicked new and named the new scheme Release 12 Solids then as you can see I made Export surfaces SOLIDS.

Used that scheme to export my dxf and it still opens without solids into V5.


I don’t believe DXF release 12 supports solids (as it’s from, like, 1995 or something). You probably need to use something more recent, 2004 is the most recent available in V5, I would go with that. @lowell why don’t we have more recent versions like 2010?


I think that’s right about R12. I see that I need to fix the dropdown to not let you set to writing solids in R12 versions. Writing R12 files, you’ll get polyface meshes instead of ACIS solids.
The reason I haven’t added writing later versions is that I don’t think there’s anything to gain by it. So far I’ve been able to export anything I wanted to from Rhino to ver. 2004. That makes it accessible to more programs that might not read later Acad files.
If there’s a need for something later, I’d be happy to consider it.


select my solid, then export as dxf, name it, select from drop down 2004 solid, go edit scheme just to see what it has and without making any changes, I export as 2004 solid.

Open this dxf into another V5 instance and still no solid.

try a simple test, draw a sphere, ditto ditto and this time opening sphere.dxf I see a solid.

I then tried my R12 solid and that also worked. so its my serious file.

Now what is wrong with my 3dm file that is stopping a solid being exported as dxf.

What do I have to run to fix it.


Are you seeing a solid or a mesh that looks like a solid?


Pretty hard to guess about that, but if you post a file, I’ll take a look


Hi, its a solid made from various sweeps and planar fills, a complex job, then inset 2mm which tends to cause imperfections on what were tricky areas to research and sweep to rail surfaces to. I then checked for exposed edges and so on.
Its a very valuable file and I get a cold sweat just thinking about letting it outside of my PC.


OK, I wouldn’t want to be responsible for any excessive sweating.
The Acad exporter skips geometry that Rhino diagnoses as invalid.
You can get some idea about that by running Check on your solid. I’m not sure that’s a conclusive test though.
If you come across something you’d like to post (or send privately) I’ll be happy to take a look.

Hi Lowell,
Is that explicitly reported somewhere? I feel uncomfortable knowing an exporter will just skip geometry upon export without informing me.


If you have a closed, solid, polysurface (“What” command or Details button on Properties panel), then that object is appropriate for solid export to the DWG/DWG file format.
If your polysurface is not closed, then it’s not valid for solid export.
Making sure it is valid is up to you. Rhino is a surface modeler that can make solids. It has no requirement to do so. That’s up to you and your modeling expertise.

Here’s a FAQ article about making solids:

Good luck

The number of objects skipped, if there are any, is reported on the command line.

It should be. ACIS supports open structures as well as closed ones. The object just needs to be VALID, not necessarily closed. Try exporting an open polysurface as Dwg/2004/solids and re-import into Rhino. It works.


You’re right. The only thing that makes sense is thinking a mesh is a surface/polysurface. A mesh will not export as a solid but it will export as a mesh provided the export settings are set accordingly.

I agree this is an issue. Often I see students come to us with problem files for the rotary knife or laser cutter - which they are required to export as dxf for compatibility reasons - and the files are missing some curves. The first thing I tell them is check for invalid objects and 99.9% of the time, that’s the problem. The thing is, 1- they don’t know the objects are invalid and 2- there is no warning that something might not have been exported…

Certainly turning on CheckNewObjects can help with #1, but an explicit warning for #2 would also be a good indication to them that something is wrong. It may seem annoying for a message box to pop up when this happens, but a real in-your-face warning would be the best in this case IMO.

Thanks, --Mitch

1 Like

I agree with Mitch and Willem.