Baking into multiple layers

New guy in this part of the forum.
I have downloaded VA and testing.
I have this setup:

and I can’t figure out how to bake it in one go while sending each group to it’s layer and keeping assigned IFC data.
Every attempt of baking (except individual, using ifc Tag, specyfying target layer) erases IFC information.


I guess you are using Human or any similar similiar plug-in (which one?) to bake the geometry assigning a layer. These components don’t keep the IFC data so it’s not possible to use them with VisualARQ for this purpose for now.

Maybe you can use the “Update Property” component instead. This way you wouldn’t be baking the geometry so you would keep each object in its corresponding layer and updating at the same time the IFC data.

I hope it helps, I send you attached an example file.
Update (13.9 KB)

Thank you.
I will put this into test in my file.

What I was looking for is an automatedd baking process, instead of going layer-by-layer.
I was checking any baking option (native, Human, Lunchbox) to get the metadata assigned.
I guess, I will stay with manual baking direct from your IFC tag component since it is giving me the information I require. I can even assigen specific data to each component (see numbering).

Does VA offer IFC exporting the results directly from GH?

another question, out of topic:

After installing VA my RH7 icon is constantly active like there is some process running in background…
not such thing for other programs

Ok, we have already added your vote to this feature in our wishlist.

Not for the moment, but I’ll add your vote to it as well.

Does that happen only with that file? If you unload and unable VA does it still happen?

It happens with any file regradless if I open Gh session or not.


It looks like there is some not visible message or active command. If you close every Rhino file, restart windows and open Rhino, it shouldn’t happen again.

I have done this mant times. It comes back. Single session, default file opened.

Ok, It is a strange behavior. First we need to know if it is a VA issue so please, if you haven’t done it before, follow these steps:

  1. Go to Rhino options and select the tab Plug-ins

  2. Choose “Plug-ins that do not ship with Rhino”

  3. Disable both Tibidabo and VisualARQ anc click OK

  4. Restart Rhino

Please, let me know if the issue still happens after this.

After disabling those two, that issue is gone.
One thing I also spotted was Rhino launching GH immediately when starting new session.
Now it is back to normal.


If you open the software using the VisualARQ icon, it should load Grasshopper but it shouldn’t open it until you do. If Grasshopper is automatically opening when you start Rhino, maybe you have it in your “Run these commands every time Rhino starts” list (check the screenshot below). Deleting the command from that list should solve the issue.

Does it mean that you have enabled Tidibidabo and VisualARQ again and the problem is solved?

My command line is clear:


In that case,Grasshopper should be loaded when you run VisualARQ, but no opened. Anyway, if it happens every time you run Rhino maybe this topic should be moved to the Grasshopper category.